Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1687987 - [4.1 > 4.2] Mention installation guide for additional repositories
Summary: [4.1 > 4.2] Mention installation guide for additional repositories
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Customer Portal Labs
Classification: Red Hat
Component: RHV Upgrade Helper
Version: unspecified
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Yunfeng Zhao
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-12 20:39 UTC by Javier Coscia
Modified: 2019-03-18 06:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-18 06:57:03 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Javier Coscia 2019-03-12 20:39:41 UTC
Description of problem:

In the Upgrade Helper tool, when checking steps to upgrade from RHV 4.1 to 4.2, we only mention to add the following repos:

~~~
# subscription-manager repos --enable=rhel-7-server-rhv-4.2-manager-rpms
# subscription-manager repos --enable=rhel-7-server-rhv-4-manager-tools-rpms
# subscription-manager repos --enable=rhel-7-server-ansible-2-rpms
~~~

This is correct, we shouldn't add any other repo here because we are doing an upgrade not installing from scratch, although, there might be scenarios where users removed previously enabled repos and the upgrade process will fail.

As an example, a user removed the `jb-eap-7-for-rhel-7-server-rpms` repository from their environment and when following the instructions from the RHV Upgrade Helper they were not able to upgrade to 4.2 due to the lack of the mentioned repo.

I think the best would be to add a reference to the installation guide for users to check the relevant repositories, or to add all the repos which are needed and a note saying to ensure the xxxx repos are present before the upgrade.



Steps to Reproduce:
1. In the RHV upgrade helper select current version as 4.1 and Target as 4.2
2. complete the information asked 
3. section 1.1 points to enable only 4.2 repos and ansible

Comment 1 Yunfeng Zhao 2019-03-13 02:21:35 UTC
Javier,
Thanks for reporting the issue.
We will investigate it.

Marina,
Can you have a look at this?
Thanks.

Yunfeng

Comment 2 Marina 2019-03-15 21:39:27 UTC
Hi Yunfeng,

Yes please.
Please mention all the repositories mentioned in the install guide:
https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.2/html/installation_guide/chap-red_hat_virtualization_manager#Enabling_the_Red_Hat_Virtualization_Manager_Repositories_standalone_install

    --enable=rhel-7-server-rpms \
    --enable=rhel-7-server-supplementary-rpms \
    --enable=rhel-7-server-rhv-4.2-manager-rpms \
    --enable=rhel-7-server-rhv-4-manager-tools-rpms \
    --enable=rhel-7-server-ansible-2-rpms \
    --enable=jb-eap-7-for-rhel-7-server-rpms

Comment 3 Yunfeng Zhao 2019-03-18 06:57:03 UTC
(In reply to Marina from comment #2)
> Hi Yunfeng,
> 
> Yes please.
> Please mention all the repositories mentioned in the install guide:
> https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.2/
> html/installation_guide/chap-
> red_hat_virtualization_manager#Enabling_the_Red_Hat_Virtualization_Manager_Re
> positories_standalone_install
> 
>     --enable=rhel-7-server-rpms \
>     --enable=rhel-7-server-supplementary-rpms \
>     --enable=rhel-7-server-rhv-4.2-manager-rpms \
>     --enable=rhel-7-server-rhv-4-manager-tools-rpms \
>     --enable=rhel-7-server-ansible-2-rpms \
>     --enable=jb-eap-7-for-rhel-7-server-rpms

Marina,
Thanks for your comfirmation.
The changes have been pushed to Prod:
https://access.redhat.com/labs/rhvupgradehelper/
Thanks.

Yunfeng


Note You need to log in before you can comment on or make changes to this bug.