Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1687894 - purpose compliance event should return same data as /consumer/:uuid/purpose_compliance API
Summary: purpose compliance event should return same data as /consumer/:uuid/purpose_c...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Candlepin
Classification: Community
Component: candlepin
Version: 2.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 2.5
Assignee: Nikos Moumoulidis
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On: 1685208
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-12 15:01 UTC by Nikos Moumoulidis
Modified: 2019-03-26 14:17 UTC (History)
5 users (show)

Fixed In Version: candlepin-2.5.13-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1685208
Environment:
Last Closed: 2019-03-26 14:17:07 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github candlepin candlepin pull 2261 None None None 2019-03-12 17:09:52 UTC

Description Nikos Moumoulidis 2019-03-12 15:01:52 UTC
+++ This bug was initially created as a clone of Bug #1685208 +++

Description of problem:

The purpose compliance event only contains 'reasons' and 'status' as useful keys for purpose compliance info. Katello reports purpose status on each field individually so it would be better to have similar data to the consumers purpose compliance API so that we can derive each status without having to reach back into Candlepin when we receive this event.


Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
1. Trigger the purpose compliance event
2. Inspect it via API

Actual results: The compliance event only has 'reasons' and 'status'


Expected results: Purpose compliance event should have all of the relevant fields for each purpose attribute - compliantSLA, nonCompliantSLA, compliantAddons, etc.


Additional info: Would be very desirable to have in 6.5 timeframe due to testing overhead & since we are currently making changes per a recent candlepin build.


Note You need to log in before you can comment on or make changes to this bug.