Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1687871 - DictValidator copies also invalid keys
Summary: DictValidator copies also invalid keys
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: vdsm
Classification: oVirt
Component: Core
Version: 4.30.8
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ---
: ---
Assignee: Vojtech Juranek
QA Contact: Lukas Svaty
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-12 14:13 UTC by Vojtech Juranek
Modified: 2019-03-12 15:21 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-12 15:21:59 UTC
oVirt Team: Storage


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 98486 master ABANDONED storage: DictValidator should copy only valid keys 2019-03-12 15:23:11 UTC

Description Vojtech Juranek 2019-03-12 14:13:32 UTC
Description of problem:
DictValidator has a copy() method which should copy all valid key:value pairs. When for some reason invalid key is present in original dict, it should be removed during the copy. This is however not the case and also invalid keys are copied.

How reproducible:
Can be easily reproduced via unit test


Actual results:
DictValidator copies also invalid keys

Expected results:
Only valid keys are copied

Comment 1 Vojtech Juranek 2019-03-12 15:21:59 UTC
Actually not a bug, but a feature...


Note You need to log in before you can comment on or make changes to this bug.