Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1687870 - Causes conflicts with `expect` package
Summary: Causes conflicts with `expect` package
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libxcrypt
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Björn 'besser82' Esser
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1688336 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-12 14:10 UTC by Enrico Scholz
Modified: 2019-03-29 19:16 UTC (History)
4 users (show)

Fixed In Version: libxcrypt-4.4.4-2.fc29 libxcrypt-4.4.4-2.fc28 libxcrypt-4.4.4-2.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-18 18:16:35 UTC


Attachments (Terms of Use)

Description Enrico Scholz 2019-03-12 14:10:48 UTC
Description of problem:

Trying to install `expect` on a recent fedora:29 docker container fails due to

# dnf install expect
Last metadata expiration check: 0:00:50 ago on Tue 12 Mar 2019 02:06:32 PM UTC.
Error: 
 Problem: problem with installed package whois-mkpasswd-5.4.1-1.fc29.x86_64
  - package whois-mkpasswd-5.4.1-1.fc29.x86_64 conflicts with expect provided by expect-5.45.4-5.fc29.x86_64
  - conflicting requests


Version-Release number of selected component (if applicable):

whois-mkpasswd-5.4.1-1.fc29.x86_64
expect-5.45.4-5.fc29.x86_64


How reproducible:

100%

Comment 1 Petr Pisar 2019-03-12 14:29:00 UTC
You need to allow dnf to remove the conflicting packages:

# dnf --allowerasing install expect

Comment 2 Petr Pisar 2019-03-14 08:39:48 UTC
*** Bug 1688336 has been marked as a duplicate of this bug. ***

Comment 3 Petr Pisar 2019-03-14 08:46:52 UTC
By the way the presence of whois-mkpasswd in your installation is caused by libxcrypt that started to recommend whois-mkpasswd in libxcrypt-4.4.3-8:

* Tue Feb 19 2019 Björn Esser <besser82@fedoraproject.org> - 4.4.3-8
- Update Obsoletes, Provides, and Requires to glibc 2.27
- Add Recommends: whois-mkpasswd for Fedora

Comment 4 Enrico Scholz 2019-03-15 11:13:53 UTC
Because component has been changed, I reopen this bug...   

This "recommends" causes major regressions when building systems from scratch (docker, anaconda) and requires changes in the workflow (manual removal of 'whois-mkpasswd').  This is ok for major version updates, but not for regular updates within one Fedora version.

Comment 5 Fedora Update System 2019-03-15 11:36:22 UTC
libxcrypt-4.4.4-2.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-5c84d4f2b4

Comment 6 Fedora Update System 2019-03-15 11:36:28 UTC
libxcrypt-4.4.4-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-3749e12736

Comment 7 Fedora Update System 2019-03-15 11:36:31 UTC
libxcrypt-4.4.4-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-26fd00240c

Comment 8 Fedora Update System 2019-03-15 21:48:36 UTC
libxcrypt-4.4.4-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-3749e12736

Comment 9 Fedora Update System 2019-03-16 18:50:24 UTC
libxcrypt-4.4.4-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-26fd00240c

Comment 10 Fedora Update System 2019-03-16 20:17:59 UTC
libxcrypt-4.4.4-2.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-5c84d4f2b4

Comment 11 Fedora Update System 2019-03-18 18:16:35 UTC
libxcrypt-4.4.4-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2019-03-25 05:28:59 UTC
libxcrypt-4.4.4-2.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2019-03-29 19:16:38 UTC
libxcrypt-4.4.4-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.