Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1687863 - kubectl OpenAPI getter errors against OpenShift 4.0
Summary: kubectl OpenAPI getter errors against OpenShift 4.0
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Master
Version: 4.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Michal Fojtik
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-12 13:56 UTC by Paul Morie
Modified: 2019-03-12 23:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-12 23:14:56 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Paul Morie 2019-03-12 13:56:52 UTC
Description of problem:

The federation CLI uses the kubectl openapi library. When used against a new 4.0 cluster created today, the library errors when calling NewOpenAPIData using the document returned by the discovery client's OpenAPI client.

Rough call trace from federation CLI code:

https://gist.github.com/pmorie/0d4e9b62ad8c33c45813948e1a294602


Version-Release number of selected component (if applicable):

4.0

How reproducible:

Use the OpenAPI getter against OpenShift.

Actual results:

Many different errors like this: SchemaError(com.github.openshift.api.oauth.v1.OAuthClientAuthorization): invalid object doesn't have additional properties

Expected results:

OpenAPI getter should work

Comment 1 Paul Morie 2019-03-12 23:14:56 UTC
CLosing, since we were vendoring an incorrect package 0~0


Note You need to log in before you can comment on or make changes to this bug.