Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1687859 - [RFE] After clicking on "Create Playbook" button under "remediate with ansible" does not show any acknowledgement
Summary: [RFE] After clicking on "Create Playbook" button under "remediate with ansi...
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Insights
Classification: Red Hat
Component: Pilot
Version: unspecified
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: mrike
QA Contact: Rob Williams
Kevin Blake
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-12 13:47 UTC by Shivam Gupta
Modified: 2019-03-29 15:54 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-29 15:54:24 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Shivam Gupta 2019-03-12 13:47:53 UTC
Description of problem: After clicking on "Create Playbook"  button while creating a playbook, it should display an acknowledgement message that playbook successfully created. 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results: After creating a playbook, it does not display any acknowledgement.


Expected results: It should display an acknowledge message that playbook successfully created.


Additional info:

Comment 1 Rob Williams 2019-03-12 13:56:08 UTC
Hi Shivam,
Thanks for filing this RFE. In the current production environment, there should be a notification which appears upon creation of the playbook. These notifications appear in the upper right hand of the screen (See attachment). 

Just to verify if it is working for your workflow, can you please follow the steps below:
1. Go to Insights > Actions 
2. Click on any category or severity level
3. Select a rule which is supported by Ansible (blue Ansible icon)
4. Select the hosts you wish to remediate, then click the "Remediate with Ansible" button.
5. Follow the prompt to create a new playbook - give it a name & click next
6. Click "Create Playbook"
7. Upon the playbook generation screen disappearing, a notification should appear in the upper right hand corner along the lines of:

Playbook created
PLAYBOOKNAMEHERE[hyperlink] has been created

Please let me know if the above steps display the notification and your feedback on it.

Thanks,
Rob

Comment 3 Shivam Gupta 2019-03-12 14:28:43 UTC
Hello Rob,

Thank you for sharing the steps.

Yes, you are right. I am able to see an notification on the upper right hand side of the portal after following the provided steps.

But, I have filed this RFE for inventory > system > configuration Assesment > Remediate with Ansible > create playbook.

After creating the playbook using above steps, there is no any notification for the creation of new playbook. 

1. Go to inventory
2. select any system from the list.
3. Click on "configuration Assessment" tab.
4. Then click on "Remediate with Ansible" button.
5. Follow the prompt to create a new playbook - give it a name & click next
6. Click "Create Playbook"
7. Then it does not display any notification for the creation of new playbook. However, created playbook can be check from Playbook tab. 

Thanks,
Shivam

Comment 4 Rob Williams 2019-03-12 14:33:11 UTC
Thanks Shivam for the additional info and detailed steps to reproduce. I have been able to successfully replicate the issue you are encountering - when generating a playbook via this flow, there is no notification that appears like there is for the other.


Note You need to log in before you can comment on or make changes to this bug.