Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 168773 - Update Xiph.org stuff to the latest version
Summary: Update Xiph.org stuff to the latest version
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libtheora
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John (J5) Palmieri
QA Contact:
URL:
Whiteboard:
: 168774 (view as bug list)
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2005-09-20 09:39 UTC by Fabio Pedretti
Modified: 2013-03-13 04:49 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-08-03 17:26:20 UTC


Attachments (Terms of Use)

Description Fabio Pedretti 2005-09-20 09:39:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; it-IT; rv:1.7.10) Gecko/20050717 Firefox/1.0.6

Description of problem:
Update to the latest version available from xiph.org

Version-Release number of selected component (if applicable):
libtheora, libvorbis, theora-tools, vorbis-tools, speex

How reproducible:
Always

Steps to Reproduce:
1. n/a
2.
3.
  

Additional info:

Comment 1 Matthias Clasen 2005-10-03 04:25:12 UTC
*** Bug 168774 has been marked as a duplicate of this bug. ***

Comment 2 Fabio Pedretti 2005-12-22 15:06:33 UTC
Latest libvorbis 1.1.2 fixed a gcc4 bug that reduced audio quality.
Also there is libogg 1.1.3.

Comment 3 Matthias Saou 2006-07-05 15:43:35 UTC
As of today, libogg, libvorbis, vorbis-tools in FC dev are the latest.
Speex too, assuming we still want to stick with 1.0.x and not jump to 1.1.x.

But there is now libtheora 1.0alpha7 too, FC dev still being at 1.0alpha5 (and
theora-tools is built from the same tarball).

The libtheora update will be trivial as there isn't a single patch in the
package. I've just tested it and it works great. It might be worth switching to
the .tar.bz2 source to save up 300kB too. If you'd like a spec file patch, just
let me know.

Comment 4 Peter Robinson 2006-07-10 11:42:59 UTC
The Xiph download page here http://www.xiph.org/downloads/ lists the 1.1.x
versions as stable so it may be worthwhile to go up to the later releases. Only
speex lists 1.0.5 as stable, but having been using speex 1.1.x on fedora for a
while i think its just as stable as 1.0.x but has some worthwhile new features
and improvements

Comment 5 Fabio Pedretti 2006-07-11 08:58:24 UTC
May also be useful to use also Vorbis aoTuV beta 4.51 patch:
http://www.geocities.jp/aoyoume/aotuv/

This patch improve vorbis quality, as reported by numerous listening tests:
http://wiki.xiph.org/index.php/VorbisEncoders
http://www.maresweb.de/listening-tests/mf-128-1/
http://www.rjamorim.com/test/index.html

Seems that vorbis development at xiph.org has stopped, so this patch wasn't
merged (but vorbis 1.1.0 merged aoTuV beta 2).

Comment 6 Matthias Saou 2006-07-27 09:40:40 UTC
Ping... it would be really nice to have libtheora alpha7 in FC6, really...

Comment 7 David Nielsen 2006-08-01 15:11:09 UTC
(In reply to comment #5)
> May also be useful to use also Vorbis aoTuV beta 4.51 patch:
> http://www.geocities.jp/aoyoume/aotuv/
> 
> This patch improve vorbis quality, as reported by numerous listening tests:
> http://wiki.xiph.org/index.php/VorbisEncoders
> http://www.maresweb.de/listening-tests/mf-128-1/
> http://www.rjamorim.com/test/index.html
> 
> Seems that vorbis development at xiph.org has stopped, so this patch wasn't
> merged (but vorbis 1.1.0 merged aoTuV beta 2).

Some hardware players have issues playing the AoTuV Ogg files, there is also an
optimized version of the patch available though I can't remember the link off hand. 

Comment 8 Fabio Pedretti 2006-08-02 07:45:15 UTC
> Some hardware players have issues playing the AoTuV Ogg files, there is also an
> optimized version of the patch available though I can't remember the link off
> hand. 

Really? This is the first time I hear this. AoTuV is also the reccomended Vorbis
Encoder of HA community:
http://wiki.hydrogenaudio.org/index.php?title=Recommended_Ogg_Vorbis
If you find any link post that here.
Thanks.


Note You need to log in before you can comment on or make changes to this bug.