Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1687632 - Error when creating the incremental CV export using hammer
Summary: Error when creating the incremental CV export using hammer
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer
Version: 6.3.5
Hardware: All
OS: All
high
high vote
Target Milestone: 6.3
Assignee: satellite6-bugs
QA Contact: vijsingh
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-12 01:09 UTC by Waldirio M Pinheiro
Modified: 2019-03-26 21:24 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-26 21:24:58 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Waldirio M Pinheiro 2019-03-12 01:09:45 UTC
Description of problem:
When exporting the CV via hammer we are able to see the content and import on the disconnected Satellite however when doing the incremental we are facing error.
"
[root@connected ~]# hammer content-view version incremental-update --content-view-version-id 1
An error occurred incrementally updating the content view:
  undefined method `prior' for nil:NilClass
[root@connected ~]#
"

Version-Release number of selected component (if applicable):
6.3.z

How reproducible:
100%

Steps to Reproduce:
1. Execute the command to export the incremental CV
"# hammer content-view version incremental-update --content-view-version-id 1"


Actual results:
---
[root@connected ~]# hammer content-view version incremental-update --content-view-version-id 1
An error occurred incrementally updating the content view:
  undefined method `prior' for nil:NilClass
[root@connected ~]# 
---


Expected results:
See the incremental data exported.

Additional info:

Comment 4 Justin Sherrill 2019-03-12 20:06:56 UTC
as discussed in irc, the incremental-update command really doesn't have anything to do with export.  You'd likely want to use:

hammer content-view version export 

with the --since TIME
flag.


Note You need to log in before you can comment on or make changes to this bug.