Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1687574 - zsh-5.7.1-1.fc30.src.rpm FTBFS
Summary: zsh-5.7.1-1.fc30.src.rpm FTBFS
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: zsh
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kamil Dudka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-11 19:03 UTC by Philippe Troin
Modified: 2019-03-12 09:00 UTC (History)
5 users (show)

Fixed In Version: zsh-5.7.1-3.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-12 09:00:02 UTC


Attachments (Terms of Use)
Mock's installed_pkgs.log for a successful rawhide build of zsh (deleted)
2019-03-11 20:24 UTC, Jason Tibbitts
no flags Details

Description Philippe Troin 2019-03-11 19:03:21 UTC
Description of problem:
zsh-5.7.1-1.fc30.src.rpm fails to build from source.

Version-Release number of selected component (if applicable):
zsh-5.7.1-1.fc30

How reproducible:
Always

Steps to Reproduce:
1. dnf download --enablerepo=rawhide --source zsh
2. rpmbuild --rebuild zsh-5.7.1-1.fc30.src.rpm

Actual results:
The build fails with:
hashnameddir.c:49:12: fatal error: rpc/types.h: No such file or directory
 #  include <rpc/types.h>
            ^~~~~~~~~~~~~
compilation terminated.
make[2]: *** [Makemod:230: hashnameddir.o] Error 1

Expected results:
The build should complete successfully.

Additional info:
Adding CPPFLAGS=-I/usr/include/tirpc seems to help.

Comment 1 Jason Tibbitts 2019-03-11 20:22:59 UTC
I cannot reproduce this.  The existing package builds quite fine in mock for me (on both F30 and rawhide), and in our buildsystem (https://koji.fedoraproject.org/koji/packageinfo?packageID=251) and in the package CI system (https://apps.fedoraproject.org/koschei/package/zsh).  I suspect that the issue falls with the environment in which you are building, as the clean environment provided by mock is fine.

Note that in general you cannot expect to do a local build of a random source package and have it simply work.  It works most of the time, but not all of the time.  One major issue is that configure scripts may detect extra things you have installed on your system and cause the build to differ in various ways.  Another possibility is that something in the default mock buildroot isn't installed on your local machine, though this is rarer and usually results in different breakage.  (Lack of redhat-rpm-config is one such package, but I don't think that's the case here.)

I can't really guess at what extra thing you might have which causes problems.  I'll attach the installed_packages.log file from a mock build.  If it's known what package causes an issue, it may be possible to work around it or, well, I've been told that BuildConflicts: exists.

Comment 2 Jason Tibbitts 2019-03-11 20:24:01 UTC
Created attachment 1543042 [details]
Mock's installed_pkgs.log for a successful rawhide build of zsh

Comment 3 Kamil Dudka 2019-03-12 08:54:56 UTC
It fails only if you have ypcat and valid NIS configuration.

Comment 4 Kamil Dudka 2019-03-12 09:00:02 UTC
downstream commit:

https://src.fedoraproject.org/cgit/rpms/zsh.git/commit/?id=711462cd


Note You need to log in before you can comment on or make changes to this bug.