Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1687391 - vdo on top of lvm2 doesn't work anymore
Summary: vdo on top of lvm2 doesn't work anymore
Keywords:
Status: CLOSED DUPLICATE of bug 1684249
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: vdo
Version: ---
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: vdo-internal
QA Contact: vdo-qe
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-11 12:37 UTC by Marius Vollmer
Modified: 2019-03-11 12:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-11 12:42:42 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description Marius Vollmer 2019-03-11 12:37:37 UTC
Description of problem:

Running "vdo create -n vdo0 --device /dev/vgroup/lvol" fails when the device is a LVM2 logical volume.

Version-Release number of selected component (if applicable):
vdo-6.2.0.293-10.el8.x86_64
lvm2-2.03.02-6.el8.x86_64

How reproducible:
Always

Steps to Reproduce:
1. vgcreate vgroup /dev/sda
2. lvcreate -n lvol -L 5G vgroup
3. vdo create -n vdo --device /dev/vdo_vgroup/lvol 

Actual results:
Creating VDO vdo
vdo: ERROR - Device /dev/vdo_vgroup/lvol excluded by a filter.

Expected results:
Creation succeeds

Additional info:
pvcreate fails in the same way:

# pvcreate /dev/vgroup/lvol 
Device /dev/vgroup/lvol excluded by a filter.

Comment 1 Andy Walsh 2019-03-11 12:40:23 UTC
This is a duplicate of BZ1684249

Comment 2 Martin Pitt 2019-03-11 12:42:42 UTC

*** This bug has been marked as a duplicate of bug 1684249 ***


Note You need to log in before you can comment on or make changes to this bug.