Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1687138 - Hang at hibernating AMD A10-9600p with amdgpu module loaded
Summary: Hang at hibernating AMD A10-9600p with amdgpu module loaded
Keywords:
Status: NEW
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 30
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-10 08:32 UTC by lonelywoolf
Modified: 2019-03-19 16:38 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)
dmesg (deleted)
2019-03-10 08:32 UTC, lonelywoolf
no flags Details
dmesg of hibernate hang with initcall_debug (deleted)
2019-03-12 17:10 UTC, lonelywoolf
no flags Details


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 106571 None None None 2019-03-14 17:50:30 UTC
Linux Kernel 201305 None None None 2019-04-11 15:15:39 UTC

Description lonelywoolf 2019-03-10 08:32:39 UTC
Created attachment 1542478 [details]
dmesg

1. When booting system in normal mode when trying to hibernate via "systemctl hibernate" system is turning off display, and freezes. No input reaction, or access via ssh. If system is booted with amdgpu module blacklisted (without initrd) - hibernate and resume is success. I was tried iommu=off and iommu=soft, nothing changes. I'm using AMD APU A10-9600p. Also, I have system with AMD APU A10-7300, it's working without issues. In Windows system is also hibernates successfully.


2. Now kernel id 5.0-rc8, same behavior was tested from kernels from 4.14 to latest.


3. This is never worked.

4. Reproducible always. Just type "systemctl hibernate" in root terminal.


5. This problem occurs with latest rawhide kernel.


6. I'm not using any other modules, only default set from Fedora.

Comment 1 lonelywoolf 2019-03-12 17:10:59 UTC
Created attachment 1543297 [details]
dmesg of hibernate hang with  initcall_debug

added  initcall_debug  to kernel options and tested.

Comment 2 lonelywoolf 2019-03-14 09:45:32 UTC
added tracker at kernel.org bugzilla with same bug.


Note You need to log in before you can comment on or make changes to this bug.