Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1687130 - dnf system-upgrade to F30 error involving openscap and scap-workbench
Summary: dnf system-upgrade to F30 error involving openscap and scap-workbench
Keywords:
Status: NEW
Alias: None
Product: Fedora
Classification: Fedora
Component: openscap
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Šimon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-10 07:33 UTC by Matt Fagnani
Modified: 2019-03-11 18:29 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Matt Fagnani 2019-03-10 07:33:58 UTC
Description of problem:

I ran the following command in F29 with updates-testing enabled to test upgrading to F30
sudo dnf system-upgrade download --refresh --releasever=30

I got the error
Problem 9: problem with installed package scap-workbench-1.2.0-2.fc29.i686
  - package scap-workbench-1.2.0-2.fc30.i686 requires libopenscap.so.25, but none of the providers can be installed
  - scap-workbench-1.2.0-2.fc29.i686 does not belong to a distupgrade repository
  - openscap-1:1.3.0-3.fc29.i686 does not belong to a distupgrade repository

openscap-1.3.0-3.fc30 has epoch 0, while openscap-1.3.0-3 in F29 has epoch 1 to fix a dnf issue where the version number of openscap-1.3.0_alpha2 was considered as higher than openscap-1.3.0. The f29 branch has the commit 
034205 which added epoch: 1 and 77f907 which added the epoch to the requires: for the openscap subpackages
https://src.fedoraproject.org/rpms/openscap/commits/f29

Those commits don't appear in the F30 branch. As a result, dnf treats openscap-1.3.0_alpha2-2.fc30 as the latest version in F30 instead of openscap-1.3.0-3.fc30. When I ran 
sudo dnf system-upgrade download --refresh --releasever=30 --skip-broken --allowerasing , scap-workbench was removed and openscap-* were downgraded to 1.3.0_alpha2-2.fc30

Removing dependent packages:
...
scap-workbench              i686   1.2.0-2.fc29             @updates-testing
                                                                             2.8 M
...

Downgrading:
...
openscap                    i686   1.3.0_alpha2-2.fc30      fedora          3.4 M
 openscap-containers         noarch 1.3.0_alpha2-2.fc30      fedora           23 k
 openscap-devel              i686   1.3.0_alpha2-2.fc30      fedora          1.5 M
 openscap-engine-sce         i686   1.3.0_alpha2-2.fc30      fedora           19 k
 openscap-engine-sce-devel   i686   1.3.0_alpha2-2.fc30      fedora           12 k
 openscap-perl               i686   1.3.0_alpha2-2.fc30      fedora          319 k
 openscap-python3            i686   1.3.0_alpha2-2.fc30      fedora          148 k
 openscap-scanner            i686   1.3.0_alpha2-2.fc30      fedora           56 k
 openscap-utils              i686   1.3.0_alpha2-2.fc30      fedora           23 k
...

openscap-1.3.0_alpha2-2.fc30 provides libopenscap.so.24, but openscap-1.3.0-3.fc30 provides libopenscap.so.25. dnf treating openscap-1.3.0_alpha2-2.fc30 as having the higher version due to the missing Epoch: 1 in openscap-1.3.0-3.fc30 might've led to the dnf error that libopenscap.so.25 wasn't available. Applying the epoch changes in 034205 and 77f907 to the F30 and master branches and rebuilding should fix this issue. Thanks.

Version-Release number of selected component (if applicable):
openscap-0:1.3.0-3.fc30
openscap-0:1.3.0_alpha2-2.fc30
openscap-1:1.3.0-3.fc29
scap-workbench-1.2.0-2.fc30

How reproducible:
2 of 2 times I tried

Steps to Reproduce:
In F29 with updates-testing enabled and openscap and scap-workbench installed
1. sudo dnf upgrade --refresh 
2. sudo dnf system-upgrade download --refresh --releasever=30
3. sudo dnf system-upgrade download --refresh --releasever=30 --skip-broken --allowerasing

Actual results:
dnf error involving openscap and scap-workbench when upgrading to F30

Expected results:
No dnf error.

Additional info:

The previous reports about the openscap and scap-workbench dnf errors for F29 were at
https://bugzilla.redhat.com/show_bug.cgi?id=1640283
https://bugzilla.redhat.com/show_bug.cgi?id=1626801
https://bodhi.fedoraproject.org/updates/FEDORA-2018-93df1fbf1b

Comment 1 Jan Černý 2019-03-11 06:40:57 UTC
Hi, changing the epoch helped us to solve previous problems with packaging the alpha versions. Do I understand it well that the epoch should be changed in Fedora 30 branch as well? What will happen after Fedora 29 end-of-life if we introduce the epoch change to Fedora 30? Will we have to revert the patch (that increments the epoch) at some point or should the patch be carried forever? Thanks.

Comment 2 Matt Fagnani 2019-03-11 18:29:50 UTC
Jan, openscap-0:1.3.0_alpha2-2.fc30 has a higher version than openscap-0:1.3.0-3.fc30 according to dnf so the same problem is in F30. I think that the openscap epoch should be 1 in F30 and F31. When upgrading from F29 to F30, dnf will downgrade the openscap packages unless they have epoch: 1 in F30. I don't think further changes should be needed after F29 is EOL. I think the Epoch: 1 should be carried forward indefinitely until the epoch may need to be increased again. I'm not a Fedora maintainer though. Thanks.


Note You need to log in before you can comment on or make changes to this bug.