Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1687083 - cloudforms appliance comes with enabled non-redhat non-product repositories that requires manual disablement to update appliance
Summary: cloudforms appliance comes with enabled non-redhat non-product repositories t...
Keywords:
Status: CLOSED DUPLICATE of bug 1678614
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Build
Version: 5.10.0
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: GA
: cfme-future
Assignee: Satoe Imaishi
QA Contact: Sudhir Mallamprabhakara
Red Hat CloudForms Documentation
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-09 16:37 UTC by Reartes Guillermo
Modified: 2019-03-11 14:01 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-11 13:32:55 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Reartes Guillermo 2019-03-09 16:37:20 UTC
Description of problem:

New CF 4.7 deployment (lab, single appliance)
After the initial appliance registration to Satellite (6.4.x) i checked for updates.
Both registration and check for updates were done from the WebUI.
I noticed that it was not checking anything and no errors were issued.

No appliance should be built with pre-enabled non-redhat repositories.

Version-Release number of selected component (if applicable):
CFME: 5.10.0.33-1
CF: 4.7
SAT: 6.4.x

How reproducible:
probably always (i cannot undo the initial registration nor deploy other appliance ATM due to other reasons)

Steps to Reproduce:
1. deploy new CF 4.7 appliance
2. register to Satellite
3. check for updates (nothing happens)
4. login via ssh 
5. do a 'yum repolist' -> non red hat repos are present

Actual results:
Foreign non redhat repositories are present and they are failing due to not being available via Satellite.

Expected results:
No foregin repositories must be present with the Cloudforms product. Each product has definied which repos should use.
Only RedHat repos must be present. (risk of getting an unsupported appliance by a legit method).

Additional info:
See yum repolist in next comment.

FIX: login to appliance and remove the offending repositories and then check for updates from the webui.

Comment 2 Reartes Guillermo 2019-03-09 16:39:31 UTC
[root@dccf47 ~]# yum repolist
Loaded plugins: product-id, search-disabled-repos, subscription-manager
https://releases.ansible.com/ansible/rpm/release/epel-7-x86_64/repodata/repomd.xml: [Errno 14] curl#6 - "Could not resolve host: releases.ansible.com; Unknown error"
Trying other mirror.
https://releases.ansible.com/ansible/rpm/release/epel-7-x86_64/repodata/repomd.xml: [Errno 14] curl#6 - "Could not resolve host: releases.ansible.com; Unknown error"
Trying other mirror.
cf-me-5.10-for-rhel-7-rpms/x86_64                                                                                                                                     | 2.4 kB  00:00:00     
cf-me-5.10-for-rhel-7-rpms/x86_64/group                                                                                                                               |  147 B  00:00:00     
cf-me-5.10-for-rhel-7-rpms/x86_64/updateinfo                                                                                                                          |  33 kB  00:00:00     
cf-me-5.10-for-rhel-7-rpms/x86_64/primary                                                                                                                             |  87 kB  00:00:00     
cf-me-5.10-for-rhel-7-rpms                                                                                                                                                           224/224
http://download.postgresql.org/pub/repos/yum/9.6/redhat/rhel-7Server-x86_64/repodata/repomd.xml: [Errno 14] curl#6 - "Could not resolve host: download.postgresql.org; Unknown error"
Trying other mirror.
https://packagecloud.io/rabbitmq/erlang/el/7/x86_64/repodata/repomd.xml: [Errno 14] curl#6 - "Could not resolve host: packagecloud.io; Unknown error"
Trying other mirror.
https://packagecloud.io/rabbitmq/erlang/el/7/SRPMS/repodata/repomd.xml: [Errno 14] curl#6 - "Could not resolve host: packagecloud.io; Unknown error"
Trying other mirror.
https://packagecloud.io/rabbitmq/rabbitmq-server/el/7/x86_64/repodata/repomd.xml: [Errno 14] curl#6 - "Could not resolve host: packagecloud.io; Unknown error"
Trying other mirror.
https://packagecloud.io/rabbitmq/rabbitmq-server/el/7/SRPMS/repodata/repomd.xml: [Errno 14] curl#6 - "Could not resolve host: packagecloud.io; Unknown error"
Trying other mirror.
rhel-7-server-ansible-2.7-rpms/x86_64                                                                                                                                 | 2.4 kB  00:00:00     
rhel-7-server-ansible-2.7-rpms/x86_64/group                                                                                                                           |  147 B  00:00:00     
rhel-7-server-ansible-2.7-rpms/x86_64/updateinfo                                                                                                                      | 7.8 kB  00:00:00     
rhel-7-server-ansible-2.7-rpms/x86_64/primary                                                                                                                         | 4.0 kB  00:00:00     
rhel-7-server-ansible-2.7-rpms                                                                                                                                                         13/13
rhel-7-server-extras-rpms/x86_64                                                                                                                                      | 2.0 kB  00:00:00     
rhel-7-server-extras-rpms/x86_64/group                                                                                                                                |  147 B  00:00:00     
rhel-7-server-extras-rpms/x86_64/updateinfo                                                                                                                           | 196 kB  00:00:00     
rhel-7-server-extras-rpms/x86_64/primary                                                                                                                              | 311 kB  00:00:00     
rhel-7-server-extras-rpms                                                                                                                                                          1064/1064
rhel-7-server-optional-rpms/7Server/x86_64                                                                                                                            | 2.0 kB  00:00:00     
rhel-7-server-optional-rpms/7Server/x86_64/group                                                                                                                      |  21 kB  00:00:00     
rhel-7-server-optional-rpms/7Server/x86_64/updateinfo                                                                                                                 | 2.3 MB  00:00:00     
rhel-7-server-optional-rpms/7Server/x86_64/primary                                                                                                                    | 4.9 MB  00:00:00     
rhel-7-server-optional-rpms                                                                                                                                                      17422/17422
rhel-7-server-rpms/7Server/x86_64                                                                                                                                     | 2.0 kB  00:00:00     
rhel-7-server-rpms/7Server/x86_64/group                                                                                                                               | 637 kB  00:00:00     
rhel-7-server-rpms/7Server/x86_64/updateinfo                                                                                                                          | 3.1 MB  00:00:00     
rhel-7-server-rpms/7Server/x86_64/primary                                                                                                                             |  33 MB  00:00:00     
rhel-7-server-rpms                                                                                                                                                               23714/23714
rhel-server-rhscl-7-rpms/7Server/x86_64                                                                                                                               | 2.0 kB  00:00:00     
rhel-server-rhscl-7-rpms/7Server/x86_64/group                                                                                                                         |  147 B  00:00:00     
rhel-server-rhscl-7-rpms/7Server/x86_64/updateinfo                                                                                                                    | 962 kB  00:00:00     
rhel-server-rhscl-7-rpms/7Server/x86_64/primary                                                                                                                       | 3.2 MB  00:00:00     
rhel-server-rhscl-7-rpms                                                                                                                                                         10935/10935


 One of the configured repositories failed (Unknown),
 and yum doesn't have enough cached data to continue. At this point the only
 safe thing yum can do is fail. There are a few ways to work "fix" this:

     1. Contact the upstream for the repository and get them to fix the problem.

     2. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     3. Run the command with the repository temporarily disabled
            yum --disablerepo=<repoid> ...

     4. Disable the repository permanently, so yum won't use it by default. Yum
        will then just ignore the repository until you permanently enable it
        again or use --enablerepo for temporary usage:

            yum-config-manager --disable <repoid>
        or
            subscription-manager repos --disable=<repoid>

     5. Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most commands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice
        compromise:

            yum-config-manager --save --setopt=<repoid>.skip_if_unavailable=true

Cannot retrieve metalink for repository: epel/x86_64. Please verify its path and try again

Only redhat.repo MUST be there (!)

[root@dccf47 yum.repos.d]# ls -l
total 40
-rw-r--r--. 1 root root   211 Feb  7 20:12 ansible-el7.repo
-rw-r--r--. 1 root root   222 Feb  7 20:12 ansible-tower.repo
-rw-r--r--. 1 root root   640 Feb  7 20:12 epel-7.repo
-rw-r--r--. 1 root root   440 Feb  7 20:12 pgdg-96-centos.repo
-rw-r--r--. 1 root root   777 Feb  7 20:12 rabbitmq.repo
-rw-r--r--. 1 root root 18063 Mar  9 13:01 redhat.repo

Comment 3 Satoe Imaishi 2019-03-11 13:32:55 UTC
Marking as duplicate.  To clarify, non-red hat repos will not exist until "Embedded Ansible" role is enabled in the UI and ansible-tower setup runs.

*** This bug has been marked as a duplicate of bug 1678614 ***


Note You need to log in before you can comment on or make changes to this bug.