Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1687040 - Latest dhcp-server version doesn't start
Summary: Latest dhcp-server version doesn't start
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dhcp
Version: rawhide
Hardware: Unspecified
OS: Linux
urgent
urgent
Target Milestone: ---
Assignee: Pavel Zhukov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-09 00:49 UTC by David Hill
Modified: 2019-03-28 09:39 UTC (History)
6 users (show)

Fixed In Version: dhcp-4.4.1-8.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-28 09:39:14 UTC


Attachments (Terms of Use)

Description David Hill 2019-03-09 00:49:15 UTC
Description of problem:
Latest dhcpcd version doesn't start
Mar  8 19:42:34 zappa dhcpd[29221]: Abandoning IP address 192.168.1.253: pinged before offer
Mar  8 19:43:14 zappa systemd[1]: dhcpd.service: Start operation timed out. Terminating.
Mar  8 19:43:14 zappa systemd[1]: dhcpd.service: Main process exited, code=killed, status=15/TERM
Mar  8 19:43:14 zappa systemd[1]: dhcpd.service: Failed with result 'timeout'.
Mar  8 19:43:14 zappa audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=dhcpd comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Update dhcpcd to latest version
2.
3.

Actual results:
Fails to start

Expected results:
No changes

Additional info:

Comment 1 David Hill 2019-03-09 01:06:03 UTC
I manually started the process with :

/usr/sbin/dhcpd -f -cf /etc/dhcp/dhcpd.conf -user dhcpd -group dhcpd --no-pid

but it times out when starting through systemd as if the daemon would never return the READY=1 status.

Comment 2 David Hill 2019-03-09 01:09:36 UTC
2019-03-08T13:41:26Z SUBDEBUG Upgrade: dhcp-common-12:4.4.1-3.fc31.noarch
2019-03-08T13:41:27Z SUBDEBUG Upgrade: dhcp-common-12:4.4.1-3.fc31.noarch
2019-03-08T13:41:27Z SUBDEBUG Installed: dhcp-libs-static-12:4.4.1-3.fc31.x86_64
2019-03-08T13:41:27Z SUBDEBUG Installed: dhcp-libs-static-12:4.4.1-3.fc31.x86_64
2019-03-08T13:54:17Z SUBDEBUG Upgrade: dhcp-client-12:4.4.1-3.fc31.x86_64
2019-03-08T13:54:18Z SUBDEBUG Upgrade: dhcp-client-12:4.4.1-3.fc31.x86_64
2019-03-08T13:54:18Z SUBDEBUG Upgrade: dhcp-server-12:4.4.1-3.fc31.x86_64
2019-03-08T13:54:19Z SUBDEBUG Upgrade: dhcp-server-12:4.4.1-3.fc31.x86_64
2019-03-08T13:57:32Z SUBDEBUG Upgraded: dhcp-server-12:4.3.6-32.fc30.x86_64
2019-03-08T13:57:32Z SUBDEBUG Upgraded: dhcp-server-12:4.3.6-32.fc30.x86_64
2019-03-08T13:59:39Z SUBDEBUG Upgraded: dhcp-client-12:4.3.6-32.fc30.x86_64
2019-03-08T13:59:39Z SUBDEBUG Upgraded: dhcp-client-12:4.3.6-32.fc30.x86_64
2019-03-08T14:01:55Z SUBDEBUG Upgraded: dhcp-common-12:4.3.6-32.fc30.noarch
2019-03-08T14:01:55Z SUBDEBUG Upgraded: dhcp-common-12:4.3.6-32.fc30.noarch

Comment 3 David Hill 2019-03-09 01:11:41 UTC
It will also daemonize without the "-f" argument:

dhcpd     6061  2.3  0.0  16744  8728 ?        Ss   20:10   0:00 /usr/sbin/dhcpd -cf /etc/dhcp/dhcpd.conf -user dhcpd -group dhcpd --no-pid

the problem is with systemd.  I tried changing the start timeout value but it still times out after that lapse of time is expired.

Comment 4 David Hill 2019-03-09 01:16:15 UTC
Changing the dhcpd.service type to simple "solved" the problem:

--- dhcpd.service.old   2019-03-08 20:15:26.108786010 -0500
+++ dhcpd.service       2019-03-08 20:15:18.545668959 -0500
@@ -6,7 +6,7 @@
 After=time-sync.target
 
 [Service]
-Type=notify
+Type=simple
 EnvironmentFile=-/etc/sysconfig/dhcpd
 ExecStart=/usr/sbin/dhcpd -f -cf /etc/dhcp/dhcpd.conf -user dhcpd -group dhcpd --no-pid $DHCPDARGS
 StandardError=null


but I'm not sure here if it's a workaround or the definitive fix.    What do you think?

Comment 5 David Hill 2019-03-26 23:30:14 UTC
The problem is still present with the new package:

[root@zappa log]# cat dnf.rpm.log | grep dhcp
2019-03-26T17:33:03Z SUBDEBUG Upgrade: dhcp-common-12:4.4.1-7.fc31.noarch
2019-03-26T17:33:04Z SUBDEBUG Upgrade: dhcp-common-12:4.4.1-7.fc31.noarch
2019-03-26T17:36:17Z SUBDEBUG Upgrade: dhcp-client-12:4.4.1-7.fc31.x86_64
2019-03-26T17:36:18Z SUBDEBUG Upgrade: dhcp-client-12:4.4.1-7.fc31.x86_64
2019-03-26T17:40:22Z SUBDEBUG Upgrade: dhcp-server-12:4.4.1-7.fc31.x86_64
2019-03-26T17:40:24Z SUBDEBUG Upgrade: dhcp-server-12:4.4.1-7.fc31.x86_64
2019-03-26T17:41:34Z SUBDEBUG Upgrade: dhcp-libs-static-12:4.4.1-7.fc31.x86_64
2019-03-26T17:41:34Z SUBDEBUG Upgrade: dhcp-libs-static-12:4.4.1-7.fc31.x86_64
2019-03-26T17:45:38Z SUBDEBUG Upgraded: dhcp-server-12:4.4.1-5.fc31.x86_64
2019-03-26T17:45:38Z SUBDEBUG Upgraded: dhcp-server-12:4.4.1-5.fc31.x86_64
2019-03-26T17:47:53Z SUBDEBUG Upgraded: dhcp-libs-static-12:4.4.1-5.fc31.x86_64
2019-03-26T17:47:53Z SUBDEBUG Upgraded: dhcp-libs-static-12:4.4.1-5.fc31.x86_64
2019-03-26T17:48:48Z SUBDEBUG Upgraded: dhcp-client-12:4.4.1-5.fc31.x86_64
2019-03-26T17:48:48Z SUBDEBUG Upgraded: dhcp-client-12:4.4.1-5.fc31.x86_64
2019-03-26T17:49:45Z SUBDEBUG Upgraded: dhcp-common-12:4.4.1-5.fc31.noarch
2019-03-26T17:49:45Z SUBDEBUG Upgraded: dhcp-common-12:4.4.1-5.fc31.noarch

Comment 6 Pavel Zhukov 2019-03-27 09:10:10 UTC
(In reply to David Hill from comment #4)
 
> but I'm not sure here if it's a workaround or the definitive fix.    What do
> you think?

Hi David.
sd_notify patch to support systemd notify was not backported properly. Should be fixed by now. 
Thank you for reporting this.


Note You need to log in before you can comment on or make changes to this bug.