Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1686920 - when /var/log/rhsm/ is missing, subscription-manager outputs rhsm logs on terminal.
Summary: when /var/log/rhsm/ is missing, subscription-manager outputs rhsm logs on ter...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.7
Hardware: All
OS: All
unspecified
high
Target Milestone: rc
: ---
Assignee: candlepin-bugs
QA Contact: Red Hat subscription-manager QE Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-08 16:36 UTC by jcastran
Modified: 2019-03-18 18:29 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-18 18:29:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3569241 Troubleshoot None RHSM logs are dumped on terminal after executing subscription-manager or yum commands 2019-03-08 16:36:08 UTC

Description jcastran 2019-03-08 16:36:08 UTC
Description of problem:
when /var/log/rhsm/ is missing, subscription-manager outputs rhsm logs on terminal.

Everytime yum is called, it calls the subscription-manager plugin and the output can be extremely excessive. This can even stop ansible which will fail when too much yum output is seen.

Version-Release number of selected component (if applicable):
subscription-manager-1.21.10-3.el7_6.x86_64

How reproducible:
Everytime

Steps to Reproduce:
1. mv /var/log/rhsm/ .
2. yum repolist

Actual results:
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-
              : manager
2019-01-23 07:26:48,781 [INFO] yum:23157:MainThread @connection.py:871 - Connection built: http_proxy=intsquid.imf.org:8080 host=subscription.rhn.redhat.com port=443 handler=/subscription auth=identity_cert ca_dir=/etc/rhsm/ca/ insecure=True
2019-01-23 07:26:48,802 [INFO] yum:23157:MainThread @connection.py:871 - Connection built: http_proxy=intsquid.imf.org:8080 host=subscription.rhn.redhat.com port=443 handler=/subscription auth=identity_cert ca_dir=/etc/rhsm/ca/ insecure=True
2019-01-23 07:26:49,092 [INFO] yum:23157:MainThread @connection.py:588 - Response: status=200, request="GET /subscription/"
''
repo id                           repo name                               status
rhel-7-server-rpms/7Server/x86_64 Red Hat Enterprise Linux 7 Server (RPMs 23382
repolist: 23382


Expected results:
repo id                           repo name                               status
rhel-7-server-rpms/7Server/x86_64 Red Hat Enterprise Linux 7 Server (RPMs 23382
repolist: 23382

AND /var/log/rhsm/ gets created so subscription-manager can log properly.

Additional info:
rpm -Va does show the directory as missing. reinstalling the subscription-manager package will resolve this issue. Depending on the entitlements this output can be extremely verbose and all caused by a missing directory that it should either create if needed, or log straight to /var/log/ instead of /var/log/rhsm/.


Note You need to log in before you can comment on or make changes to this bug.