Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1686843 - worker memory size selection reverts to 200mb if selecting a value of 1gb in the Workers tab
Summary: worker memory size selection reverts to 200mb if selecting a value of 1gb in ...
Keywords:
Status: CLOSED DUPLICATE of bug 1656873
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance
Version: 5.10.1
Hardware: All
OS: All
unspecified
medium
Target Milestone: GA
: 5.10.3
Assignee: Joe Rafaniello
QA Contact: Sudhir Mallamprabhakara
Red Hat CloudForms Documentation
URL:
Whiteboard:
Depends On:
Blocks: 1692488
TreeView+ depends on / blocked
 
Reported: 2019-03-08 13:28 UTC by Felix Dewaleyne
Modified: 2019-03-25 17:15 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-12 14:44:41 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Felix Dewaleyne 2019-03-08 13:28:52 UTC
Description of problem:
worker memory size selection reverts to 200mb if selecting a value of 1gb in the Workers tab

Version-Release number of selected component (if applicable):
5.10.1

How reproducible:
all the time

Steps to Reproduce:
1.go to configure > configuration 
2.go to the zone > an_appliance_here
3.go to the workers tab
4. set the size to 250gb and save
5. set the size to 1gb and save

Actual results:
on step 5, after saving the value displayed will be 200mb.

Expected results:
on step 5, the result should be to display the 1gb size.

Additional info:
was previously happening for all values on CF 4.6

Comment 2 Joe Rafaniello 2019-03-08 17:19:08 UTC
Can you verify the steps again:

4) says 250 GB (I'm assuming 250 MB but it's unclear)
5) says 1 GB   (I'm assuming 1 GB)

Why is step 4 needed?  Is the value saved properly after step 4?

Is this for ANY worker or specific worker pulldowns?

Finally, where are you "displaying" the result after to see the 200 MB value?

What does the pulldown show after saving, leaving the page and coming back?  What about advanced settings?

Comment 3 Felix Dewaleyne 2019-03-11 13:56:20 UTC
if you set it to 250mb (sorry for any typo) that is properly behaving. if you set it to 1gb it isn't.

issue has only been tested against the generic worker. I can't comment on other workers.

after the selection is made the page refreshes instantly but you can also load any other tab and then go back to the workers tab for the same effect.

Comment 4 Joe Rafaniello 2019-03-11 18:53:53 UTC
Felix, 
In the UI, with 5.10.1.2, I was able to do this in the dropdowns in the workers tab:

1) change generic worker to 500 MB, save and see 500 MB in dropdown... leaving the tab and returning still show 500 MB
2) change generic worker to 1 GB, save and see 200 MB in dropdown...  leaving the tab and returning still show 200 MB (advanced settings shows 1 GB in bytes)

This appears to be a visual problem only, since the data is saved correctly but we fail to show the current setting in the dropdown if the current setting is 1 GB or higher.

If so, that's a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1656873

Can you confirm it's a duplicate of this?


Note, it's fixed on master and scheduled for 5.10.2.x

Comment 6 Joe Rafaniello 2019-03-12 14:44:41 UTC

*** This bug has been marked as a duplicate of bug 1656873 ***


Note You need to log in before you can comment on or make changes to this bug.