Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1686778 - Lost analog stereo duplex profile for USB audio device (JABRA Evolve 30 II)
Summary: Lost analog stereo duplex profile for USB audio device (JABRA Evolve 30 II)
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: 29
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-08 10:01 UTC by Enrico Tagliavini
Modified: 2019-03-08 13:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-08 13:42:28 UTC


Attachments (Terms of Use)
pactl list output (deleted)
2019-03-08 10:01 UTC, Enrico Tagliavini
no flags Details

Description Enrico Tagliavini 2019-03-08 10:01:28 UTC
Created attachment 1542082 [details]
pactl list output

Note: I'm opening this bug against pulseaudio but am not sure it's a pulseaudio direct fault. However I'm completely lost at what it could be.

Description of problem:
I cannot use the microphone and the hear pieces of the JABRA Evolve 30 II at the same time any longer as the pulseaudio stereo duplex profile is missing. I can either use the JABRA as an input (microphone) or output (head speakers), but not both at the same time. I was able to until not long ago (no more than a month, but probably just a couple of weeks).


Version-Release number of selected component (if applicable):
pulseaudio-12.2-1.fc29.x86_64
kernel-4.20.13-200.fc29.x86_64
kernel-4.18.16-300.fc29.x86_64 (I tried an older kernel just in case it was a kernel issue)


How reproducible:
Always


Steps to Reproduce:
1. Attach a JABRA Evolve 30 II USB headset to the computer
2. check in pavucontrol / pactl list the duplex profile for this device is missing

Actual results:
Microphone and speakers cannot be used at the same time with the same pulseaudio profile


Expected results:
Microfone and speakers should work at the same time with a duplex profile.


Additional info:
I've tried to downgrade the kernel to an older version, just in case it was a snag in a recent kernel update. Kernel 4.18 made no difference, so this is likely not kernel related.

I've also tried to disable ucm in module-udev-detect in /etc/pulseaudio/default.pa

   load-module module-udev-detect use_ucm=0

but this also made no difference.

Comment 1 Enrico Tagliavini 2019-03-08 13:42:28 UTC
Mhm sorry for the noise, turns out my new USB keypad mess up the USB hub.


Note You need to log in before you can comment on or make changes to this bug.