Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1686731 - udisksd crashes with SIGSEGV in g_mutex_lock
Summary: udisksd crashes with SIGSEGV in g_mutex_lock
Keywords:
Status: CLOSED DUPLICATE of bug 1643350
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: udisks2
Version: 7.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Tomáš Bžatek
QA Contact: Storage QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-08 07:49 UTC by Yuki Okada
Modified: 2019-03-08 09:06 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-08 09:06:10 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Yuki Okada 2019-03-08 07:49:23 UTC
Description of problem:

udisksd occasionally crashes in g_mutex_lock. Here is a backtrace collected by ABRT.

$ cat core_backtrace 
{   "signal": 11
,   "executable": "/usr/libexec/udisks2/udisksd"
,   "stacktrace":
      [ {   "crash_thread": true
        ,   "frames":
              [ {   "address": 140693540978261
                ,   "build_id": "61c2ff89232b4746987bf679fda8bd047758de60"
                ,   "build_id_offset": 593493
                ,   "function_name": "g_mutex_lock"
                ,   "file_name": "/usr/lib64/libglib-2.0.so.0.5600.1"
                }
              , {   "address": 140693540689032
                ,   "build_id": "61c2ff89232b4746987bf679fda8bd047758de60"
                ,   "build_id_offset": 304264
                ,   "function_name": "g_source_destroy_internal"
                ,   "file_name": "/usr/lib64/libglib-2.0.so.0.5600.1"
                }
              , {   "address": 94917444256511
                ,   "build_id": "1536b2ca58bec5a585fe3ba7b4b184c749b7c125"
                ,   "build_id_offset": 103167
                ,   "function_name": "main"
                ,   "file_name": "/usr/libexec/udisks2/udisksd"
                } ]
        } ]
}

Version-Release number of selected component (if applicable):
udisks2-2.7.3-8.el7.x86_64

How reproducible:
Occasionally

Steps to Reproduce:
Unknown

Actual results:
udisksd crashes

Expected results:
udisksd does not crash

Additional info:
This issue is reported in https://github.com/storaged-project/udisks/issues/417, and seems to be fixed in https://github.com/storaged-project/udisks/pull/515.

Comment 3 Tomáš Bžatek 2019-03-08 09:06:10 UTC

*** This bug has been marked as a duplicate of bug 1643350 ***


Note You need to log in before you can comment on or make changes to this bug.