Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1686508 - Raspberry Pi 3 fails to boot recent F29 IoT images
Summary: Raspberry Pi 3 fails to boot recent F29 IoT images
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: uboot-tools
Version: 29
Hardware: aarch64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: IoT
TreeView+ depends on / blocked
 
Reported: 2019-03-07 15:29 UTC by Paul Whalen
Modified: 2019-04-03 03:30 UTC (History)
7 users (show)

Fixed In Version: bcm283x-firmware-20190212-2.83977fe.fc29 uboot-tools-2018.09-3.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-29 19:17:09 UTC


Attachments (Terms of Use)

Description Paul Whalen 2019-03-07 15:29:09 UTC
Description of problem:

Updated Fedora 29 IoT aarch64 images fail to boot on the Raspberry Pi 3 and only show the initial efi messages.


Version-Release number of selected component (if applicable):
All updated f29 IoT composes. 


Updating (rpm-ostree upgrade) from the Fedora-IoT-29-20181206.0 works, but deploying updated images fail to boot.

Comment 1 Paul Whalen 2019-03-07 15:58:05 UTC
Attempting to boot Fedora-IoT-30-20190301.0.aarch64.raw.xz 

MMC:   mmc@7e202000: 0, mmc@7e300000: 1
Loading Environment from FAT... *** Warning - bad CRC, using default environment

In:    serial
Out:   vidconsole
Err:   vidconsole
Net:   No ethernet found.
starting USB...
USB0:   scanning bus 0 for devices... 3 USB Device(s) found
       scanning usb for storage devices... 0 Storage Device(s) found
Hit any key to stop autoboot:  0 
switch to partitions #0, OK
mmc0 is current device
Scanning mmc 0:1...
Found EFI removable media binary efi/fedora/grubaa64.efi
libfdt fdt_check_header(): FDT_ERR_BADMAGIC
Scanning disk mmc@7e202000.blk...
Card did not respond to voltage select!
Scanning disk mmc@7e300000.blk...
Disk mmc@7e300000.blk not ready
Found 4 disks
FDT memrsv map 0: Failed to add to map
1886968 bytes read in 89 ms (20.2 MiB/s)
libfdt fdt_check_header(): FDT_ERR_BADMAGIC
FDT memrsv map 0: Failed to add to map
## Starting EFI application at 00080000 ...
Waiting for Ethernet connection... 


EFI stub: Booting Linux Kernel...
EFI stub: EFI_RNG_PROTOCOL unavailable, no randomness supplied
EFI stub: Using DTB from configuration table
EFI stub: Exiting boot services and installing virtual address map...

Comment 2 Paul Whalen 2019-03-07 16:09:44 UTC
Using the dtb's from release 1 and removing the updated dtb's (bcm27*.dtb), the Raspberry Pi 3 boots as expected.

Comment 3 Fedora Update System 2019-03-07 18:03:52 UTC
bcm283x-firmware-20190212-2.83977fe.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-cb85393cad

Comment 4 Fedora Update System 2019-03-07 18:04:00 UTC
bcm283x-firmware-20190212-2.83977fe.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-486c6579ea

Comment 5 Fedora Update System 2019-03-07 18:37:35 UTC
bcm283x-firmware-20190212-2.83977fe.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-486c6579ea

Comment 6 Fedora Update System 2019-03-07 20:32:08 UTC
bcm283x-firmware-20190212-2.83977fe.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-cb85393cad

Comment 7 Fedora Update System 2019-03-13 15:54:18 UTC
bcm283x-firmware-20190212-3.83977fe.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-c2a7014f37

Comment 8 Fedora Update System 2019-03-13 17:11:04 UTC
bcm283x-firmware-20190212-2.83977fe.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-486c6579ea

Comment 9 Fedora Update System 2019-03-14 20:59:07 UTC
bcm283x-firmware-20190212-2.83977fe.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-486c6579ea

Comment 10 Fedora Update System 2019-03-15 18:29:11 UTC
bcm283x-firmware-20190212-2.83977fe.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2019-03-17 10:42:51 UTC
bcm283x-firmware-20190212-4.83977fe.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-8528d07711

Comment 12 Peter Robinson 2019-03-17 13:50:53 UTC
This isn't a firmware/DT problem at all, it's a problematic U-Boot UEFI patch

Comment 13 Peter Robinson 2019-03-17 13:54:09 UTC
Note this is completely reproducible on standard Fedora with uboot-tools-2018.09-2.fc29 on aarch64, I suspect it also causes issues on other platforms, it was probably missed for so long because we don't respin arm disk images post GA and people tend not to update U-Boot if it's not broken.

Comment 14 Fedora Update System 2019-03-17 17:28:20 UTC
uboot-tools-2018.09-3.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-ebfd1fe19b

Comment 15 Fedora Update System 2019-03-17 20:59:24 UTC
bcm283x-firmware-20190212-4.83977fe.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-8528d07711

Comment 16 Fedora Update System 2019-03-18 17:47:52 UTC
uboot-tools-2018.09-3.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-ebfd1fe19b

Comment 17 Fedora Update System 2019-03-29 19:17:09 UTC
bcm283x-firmware-20190212-4.83977fe.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2019-04-03 03:30:41 UTC
uboot-tools-2018.09-3.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.