Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1686451 - openstack undercloud install fails with os-refresh-config error
Summary: openstack undercloud install fails with os-refresh-config error
Keywords:
Status: CLOSED DUPLICATE of bug 1672446
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: RHOS Maint
QA Contact: Gurenko Alex
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-07 13:43 UTC by Kevin Jones
Modified: 2019-03-07 22:37 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-07 22:37:40 UTC
Target Upstream Version:


Attachments (Terms of Use)
sosreport from undercloud vm (deleted)
2019-03-07 13:47 UTC, Kevin Jones
no flags Details

Description Kevin Jones 2019-03-07 13:43:11 UTC
Description of problem:
Running openstack undercloud install on latest CDN updates fails consistently with the following error.

2019-03-07 08:34:56,598 INFO: + echo 'puppet apply exited with exit code 6'
2019-03-07 08:34:56,599 INFO: puppet apply exited with exit code 6
2019-03-07 08:34:56,599 INFO: + '[' 6 '!=' 2 -a 6 '!=' 0 ']'
2019-03-07 08:34:56,599 INFO: + exit 6
2019-03-07 08:34:56,600 INFO: [2019-03-07 08:34:56,599] (os-refresh-config) [ERROR] during configure phase. [Command '['dib-run-parts', '/usr/libexec/os-refresh-config/configure.d']' returned non-zero exit status 1]
2019-03-07 08:34:56,600 INFO: 
2019-03-07 08:34:56,601 INFO: [2019-03-07 08:34:56,599] (os-refresh-config) [ERROR] Aborting...
2019-03-07 08:34:56,610 DEBUG: An exception occurred
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 2332, in install
    _run_orc(instack_env)
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 1599, in _run_orc
    _run_live_command(args, instack_env, 'os-refresh-config')
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 668, in _run_live_command
    raise RuntimeError('%s failed. See log for details.' % name)
RuntimeError: os-refresh-config failed. See log for details.
2019-03-07 08:34:56,613 ERROR: 
#############################################################################
Undercloud install failed.

Reason: os-refresh-config failed. See log for details.

See the previous output for details about what went wrong.  The full install
log can be found at /home/stack/.instack/install-undercloud.log.

#############################################################################


Version-Release number of selected component (if applicable):
13

How reproducible:
100%

Steps to Reproduce:
1. Prep undercloud virtual machine based on director guide
2. run openstack undercloud install

Actual results:
undercloud install fails

Expected results:
undercloud install succeeds

Additional info:
sosreport to follow

Comment 1 Kevin Jones 2019-03-07 13:47:15 UTC
Created attachment 1541844 [details]
sosreport from undercloud vm

Comment 2 Kevin Jones 2019-03-07 14:39:06 UTC
No idea if this is related.

I ran the failed command:
sudo dib-run-parts /usr/libexec/os-refresh-config/configure.d

...
   Config retrieval: 46.32
             Exec: 46.80
   Keystone user role: 49.91
          Service: 6.20
    Ironic config: 8.81
    Keystone user: 80.72
Version:
           Config: 1551968764
           Puppet: 4.8.2
+ rc=6
+ set -e
+ echo 'puppet apply exited with exit code 6'
puppet apply exited with exit code 6
+ '[' 6 '!=' 2 -a 6 '!=' 0 ']'
+ exit 6


And see this in output:
Notice: /Stage[main]/Main/Exec[ceilo-gnocchi-upgrade]/returns: ceilometer-upgrade: error: unrecognized arguments: --skip-metering-database
Error: ceilometer-upgrade --skip-metering-database returned 2 instead of one of [0]
Error: /Stage[main]/Main/Exec[ceilo-gnocchi-upgrade]/returns: change from notrun to 0 failed: ceilometer-upgrade --skip-metering-database returned 2 instead of one of [0]

Comment 3 Alex Schultz 2019-03-07 22:37:40 UTC

*** This bug has been marked as a duplicate of bug 1672446 ***


Note You need to log in before you can comment on or make changes to this bug.