Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1686447 - matrix-synapse prevents update to latest python2-prometheus_client
Summary: matrix-synapse prevents update to latest python2-prometheus_client
Status: NEW
Alias: None
Product: Fedora
Classification: Fedora
Component: matrix-synapse
Version: 29
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Jeremy Cline
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2019-03-07 13:32 UTC by Xavier Bachelot
Modified: 2019-03-11 10:51 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed:

Attachments (Terms of Use)

Description Xavier Bachelot 2019-03-07 13:32:36 UTC
Description of problem:
On an otherwise fully updated Fedora 29 :

 Problem: package matrix-synapse- requires python2.7dist(prometheus-client) < 0.4.0, but none of the providers can be installed
  - cannot install both python2-prometheus_client-0.6.0-1.fc29.noarch and python2-prometheus_client-0.2.0-3.fc29.noarch
  - cannot install both python2-prometheus_client-0.2.0-3.fc29.noarch and python2-prometheus_client-0.6.0-1.fc29.noarch
  - cannot install the best update candidate for package python2-prometheus_client-0.2.0-3.fc29.noarch
  - cannot install the best update candidate for package matrix-synapse-

Comment 1 Jeremy Cline 2019-03-10 19:39:37 UTC
Unfortunately, a new, backwards-incompatible version of prometheus_client was pushed to stable Fedora repositories. Upstream Synapse still pins its version to 0.4 or lower so the only thing I can really do is work on Synapse to get it working with whatever the new API is. I'm not really sure when I'll have time to do that.

Comment 2 Xavier Bachelot 2019-03-11 10:51:58 UTC
Thanks for the answer.
Unfortunately, 0.99.2 still has the prometheus_client dep restricted to < 0.4, but there is a note about the change just above it.
Following the links, one eventually hits, so upstream definitely knows about the issue.
Also, it seems code is starting to get fixed for prometheus_client >= 0.4 :

Note You need to log in before you can comment on or make changes to this bug.