Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1686401 - [RFE] Doc RFE - Document the usage of "%" operator in value attribute
Summary: [RFE] Doc RFE - Document the usage of "%" operator in value attribute
Keywords:
Status: CLOSED DUPLICATE of bug 1686147
Alias: None
Product: Beaker
Classification: Community
Component: Doc
Version: develop
Hardware: Unspecified
OS: Unspecified
low
medium vote
Target Milestone: ---
Assignee: beaker-dev-list
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-07 11:40 UTC by Tomas Klohna 🔧
Modified: 2019-03-08 07:04 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-08 07:01:58 UTC


Attachments (Terms of Use)

Description Tomas Klohna 🔧 2019-03-07 11:40:27 UTC
We support the usage of "%" but it isn't documented anywhere.
For example:
<hostRequires>
 <and>
   <hostname op="like" value="gigabyte-r120%bos%"/>
  </and>
<system_type value="Machine"/>
</hostRequires>

Is a valid segment of recipe XML and will match all values containing `gigabyte-r120 ... bos ...` string.

Comment 1 Martin Styk 2019-03-08 07:01:58 UTC

*** This bug has been marked as a duplicate of bug 1686147 ***


Note You need to log in before you can comment on or make changes to this bug.