Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1686369 - Web UI unable to detect instance created by lib389 running on the same machine
Summary: Web UI unable to detect instance created by lib389 running on the same machine
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Directory Server
Classification: Red Hat
Component: UI - General UI
Version: 8.0
Hardware: All
OS: All
high
high
Target Milestone: DS11.0
: ---
Assignee: mreynolds
QA Contact: RHDS QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-07 10:58 UTC by Anuj Borah
Modified: 2019-03-18 16:12 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-18 16:12:13 UTC
Target Upstream Version:


Attachments (Terms of Use)
video demo 1 (deleted)
2019-03-07 10:58 UTC, Anuj Borah
no flags Details
video demo 2 (deleted)
2019-03-07 10:59 UTC, Anuj Borah
no flags Details
video demo 3 (deleted)
2019-03-07 11:00 UTC, Anuj Borah
no flags Details

Description Anuj Borah 2019-03-07 10:58:57 UTC
Created attachment 1541803 [details]
video demo 1

Description of problem:

Web UI unable to detect instance created by lib389 running on the same machine 

Steps:

create a DS instance with lib389 refresh the cockpit the new instance will be shown in instance tab but it will give error:

{'desc': "Can't contact LDAP server", 'errno': 2, 'info': 'No such file or directory'}

But when i delete the instance from actions tab , it gets delete perfectly
  

Version-Release number of selected component (if applicable):

389-ds-base-1.4.0.20-7.module+el8+2809+aaa18b6a.x86_64

How reproducible:

Always

Steps to Reproduce:
Mentioned above

Comment 1 Anuj Borah 2019-03-07 10:59:45 UTC
Created attachment 1541804 [details]
video demo 2

Comment 2 Anuj Borah 2019-03-07 11:00:18 UTC
Created attachment 1541805 [details]
video demo 3

Comment 3 mreynolds 2019-03-18 16:12:13 UTC
So the way you are creating the instance is the problem.  You are not using dscreate.  You are using the lib389 testing framework which currently does NOT use dscreate.  It uses the old perl script setup-ds.pl which does not enable LDAPI by default (unlike dscreate).  So that instance will not work in the UI.  And the error message given in UI states that LDAPI is probably not enabled :)  If you enable LDAPI in that instance it should work in the UI.

So the everything is working as expected from what I am seeing here.

I am going to close this as not a bug, but if you can reproduce the issue using dscreate please reopen this bug.


Note You need to log in before you can comment on or make changes to this bug.