Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1686334 - Dynamic provisioning successful with invalid chapauthenabled
Summary: Dynamic provisioning successful with invalid chapauthenabled
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gluster-block
Version: ocs-3.11
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Prasanna Kumar Kalever
QA Contact: Rahul Hinduja
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-07 09:44 UTC by Arun Kumar
Modified: 2019-03-10 08:57 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-10 08:57:57 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Arun Kumar 2019-03-07 09:44:48 UTC
Description of problem:
When I set chapautheanbled parameter to any invalid value and try to create PVC it get successfully created

Version-Release number of selected component (if applicable):
# oc version
oc v3.11.82
kubernetes v1.11.0+d4cacc0
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://dhcp53-226.lab.eng.blr.redhat.com:8443
openshift v3.11.82
kubernetes v1.11.0+d4cacc0

gluster-block-0.2.1-31.el7rhgs.x86_64
glusterfs-libs-3.12.2-43.el7.x86_64
glusterfs-client-xlators-3.12.2-43.el7.x86_64
glusterfs-3.12.2-43.el7.x86_64
glusterfs-fuse-3.12.2-43.el7.x86_64
glusterfs-server-3.12.2-45.el7rhgs.x86_64
heketi-client-8.0.0-10.el7rhgs.x86_64

How reproducible:


Steps to Reproduce:
1. Create SC with an invalid parameter chapautheanbled: 'hello'
2. Try to create a PVC that is associated with the same SC.
 


Actual results:
PVC get into Bound state

Expected results:
Provisioning should fail.

Additional info:
[root@dhcp53-226 scripts]# sh pvc-create.sh pvc1 1
persistentvolumeclaim/pvc1 created
[root@dhcp53-226 scripts]# oc describe pvc pvc1
Name:          pvc1
Namespace:     glusterfs
StorageClass:  block-sc1
Status:        Pending
Volume:        
Labels:        <none>
Annotations:   control-plane.alpha.kubernetes.io/leader={"holderIdentity":"b0a8eb31-3fce-11e9-883d-0a580a820003","leaseDurationSeconds":15,"acquireTime":"2019-03-07T09:15:28Z","renewTime":"2019-03-07T09:15:36Z","lea...
               volume.beta.kubernetes.io/storage-class=block-sc1
               volume.beta.kubernetes.io/storage-provisioner=gluster.org/glusterblock
Finalizers:    [kubernetes.io/pvc-protection]
Capacity:      
Access Modes:  
Events:
  Type    Reason                Age               From                                                           Message
  ----    ------                ----              ----                                                           -------
  Normal  Provisioning          10s               gluster.org/glusterblock b0a8eb31-3fce-11e9-883d-0a580a820003  External provisioner is provisioning volume for claim "glusterfs/pvc1"
  Normal  ExternalProvisioning  2s (x8 over 10s)  persistentvolume-controller                                    waiting for a volume to be created, either by external provisioner "gluster.org/glusterblock" or manually created by system administrator
[root@dhcp53-226 scripts]# vim pvc-create.sh 
[root@dhcp53-226 scripts]# vim block-storageClass.sh
[root@dhcp53-226 scripts]# vim pvc-create.sh 
[root@dhcp53-226 scripts]# oc describe pvc pvc1
Name:          pvc1
Namespace:     glusterfs
StorageClass:  block-sc1
Status:        Bound
Volume:        pvc-8cd6c981-40b9-11e9-b113-001a4a16017e
Labels:        <none>
Annotations:   control-plane.alpha.kubernetes.io/leader={"holderIdentity":"b0a8eb31-3fce-11e9-883d-0a580a820003","leaseDurationSeconds":15,"acquireTime":"2019-03-07T09:15:28Z","renewTime":"2019-03-07T09:15:40Z","lea...
               pv.kubernetes.io/bind-completed=yes
               pv.kubernetes.io/bound-by-controller=yes
               volume.beta.kubernetes.io/storage-class=block-sc1
               volume.beta.kubernetes.io/storage-provisioner=gluster.org/glusterblock
Finalizers:    [kubernetes.io/pvc-protection]
Capacity:      1Gi
Access Modes:  RWO
Events:
  Type    Reason                 Age              From                                                           Message
  ----    ------                 ----             ----                                                           -------
  Normal  Provisioning           1m               gluster.org/glusterblock b0a8eb31-3fce-11e9-883d-0a580a820003  External provisioner is provisioning volume for claim "glusterfs/pvc1"
  Normal  ExternalProvisioning   1m (x9 over 1m)  persistentvolume-controller                                    waiting for a volume to be created, either by external provisioner "gluster.org/glusterblock" or manually created by system administrator
  Normal  ProvisioningSucceeded  1m               gluster.org/glusterblock b0a8eb31-3fce-11e9-883d-0a580a820003  Successfully provisioned volume pvc-8cd6c981-40b9-11e9-b113-001a4a16017e
[root@dhcp53-226 scripts]# oc describe pvc pvc1
Name:          pvc1
Namespace:     glusterfs
StorageClass:  block-sc1
Status:        Bound
Volume:        pvc-8cd6c981-40b9-11e9-b113-001a4a16017e
Labels:        <none>
Annotations:   control-plane.alpha.kubernetes.io/leader={"holderIdentity":"b0a8eb31-3fce-11e9-883d-0a580a820003","leaseDurationSeconds":15,"acquireTime":"2019-03-07T09:15:28Z","renewTime":"2019-03-07T09:15:40Z","lea...
               pv.kubernetes.io/bind-completed=yes
               pv.kubernetes.io/bound-by-controller=yes
               volume.beta.kubernetes.io/storage-class=block-sc1
               volume.beta.kubernetes.io/storage-provisioner=gluster.org/glusterblock
Finalizers:    [kubernetes.io/pvc-protection]
Capacity:      1Gi
Access Modes:  RWO
Events:
  Type    Reason                 Age              From                                                           Message
  ----    ------                 ----             ----                                                           -------
  Normal  Provisioning           1m               gluster.org/glusterblock b0a8eb31-3fce-11e9-883d-0a580a820003  External provisioner is provisioning volume for claim "glusterfs/pvc1"
  Normal  ExternalProvisioning   1m (x9 over 1m)  persistentvolume-controller                                    waiting for a volume to be created, either by external provisioner "gluster.org/glusterblock" or manually created by system administrator
  Normal  ProvisioningSucceeded  1m               gluster.org/glusterblock b0a8eb31-3fce-11e9-883d-0a580a820003  Successfully provisioned volume pvc-8cd6c981-40b9-11e9-b113-001a4a16017e

[root@dhcp53-226 scripts]#  oc describe sc block-sc1
Name:                  block-sc1
IsDefaultClass:        No
Annotations:           <none>
Provisioner:           gluster.org/glusterblock
Parameters:            chapauthenabled=hello,hacount=3,restsecretName=heketi-secret-block,restsecretNamespace=glusterfs,resturl=http://heketi-storage-glusterfs.router.default.svc.cluster.local,restuser=admin,volumenameprefix=blk
AllowVolumeExpansion:  <unset>
MountOptions:          <none>
ReclaimPolicy:         Delete
VolumeBindingMode:     Immediate
Events:                <none>
[root@dhcp53-226 scripts]# heketi-cli blockvolume list|grep pvc1
Id:4d7b0d82a20c18b5051e20ac6f4c905c    Cluster:56a2b4cdecdf18b04f7ef47fc1fc4f89    Name:blk_glusterfs_pvc1_8ce23c84-40b9-11e9-883d-0a580a820003
[root@dhcp53-226 scripts]# heketi-cli blockvolume info 4d7b0d82a20c18b5051e20ac6f4c905c
Name: blk_glusterfs_pvc1_8ce23c84-40b9-11e9-883d-0a580a820003
Size: 1
Volume Id: 4d7b0d82a20c18b5051e20ac6f4c905c
Cluster Id: 56a2b4cdecdf18b04f7ef47fc1fc4f89
Hosts: [10.70.53.232 10.70.53.231 10.70.53.200]
IQN: iqn.2016-12.org.gluster-block:7822c727-56ca-4b65-9546-59f240b4c13c
LUN: 0
Hacount: 3
Username: 
Password: 
Block Hosting Volume: 758e230869a51d7e320b51bab07b837e
[root@dhcp53-226 scripts]# oc rsh glusterfs-storage-
glusterfs-storage-7bfm9  glusterfs-storage-8xkhx  glusterfs-storage-svzvn  
[root@dhcp53-226 scripts]# oc rsh glusterfs-storage-svzvn 
c1_8ce23c84-40b9-11e9-883d-0a580a82000369a51d7e320b51bab07b837e/blk_glusterfs_pv 
NAME: blk_glusterfs_pvc1_8ce23c84-40b9-11e9-883d-0a580a820003
VOLUME: vol_758e230869a51d7e320b51bab07b837e
GBID: 7822c727-56ca-4b65-9546-59f240b4c13c
SIZE: 1.0 GiB
HA: 3
PASSWORD: 
EXPORTED ON: 10.70.53.232 10.70.53.231 10.70.53.200
sh-4.2# exit

Comment 2 Yaniv Kaul 2019-03-10 08:57:57 UTC
Doesn't seem to be interesting enough right now to be fixed (due to capacity).
Deferring right now.


Note You need to log in before you can comment on or make changes to this bug.