Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1685808 - Failed dependencies occur during install systemtap package.
Summary: Failed dependencies occur during install systemtap package.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: ovirt-node
Classification: oVirt
Component: General
Version: 4.3
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: ---
: ---
Assignee: Yuval Turgeman
QA Contact: Wei Wang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-06 07:23 UTC by Wei Wang
Modified: 2019-03-06 10:32 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-06 08:08:57 UTC
oVirt Team: Node


Attachments (Terms of Use)
Log files (deleted)
2019-03-06 07:23 UTC, Wei Wang
no flags Details

Description Wei Wang 2019-03-06 07:23:47 UTC
Created attachment 1541235 [details]
Log files

Description of problem:
Failed dependencies occur during install systemtap package.

---> Package kernel-headers.x86_64 0:3.10.0-957.5.1.el7 will be installed
--> Finished Dependency Resolution
Error: Package: gcc-4.8.5-36.el7.x86_64 (rhel-7-server-rhvh-4-rpms)
           Requires: libgomp = 4.8.5-36.el7
           Installed: libgomp-4.8.5-36.el7_6.1.x86_64 (installed)
               libgomp = 4.8.2-16.el7_6
               libgomp = 4.8.5-36.el7_6.1
           Available: libgomp-4.8.5-16.el7_4.1.x86_64 (rhel-7-server-rhvh-4-rpms)
               libgomp = 4.8.2-16.el7_4
               libgomp = 4.8.5-16.el7_4.1
           Available: libgomp-4.8.5-16.el7_4.2.x86_64 (rhel-7-server-rhvh-4-rpms)
               libgomp = 4.8.2-16.el7_4
               libgomp = 4.8.5-16.el7_4.2
           Available: libgomp-4.8.5-28.el7.x86_64 (rhel-7-server-rhvh-4-rpms)
               libgomp = 4.8.2-16.el7
               libgomp = 4.8.5-28.el7
           Available: libgomp-4.8.5-28.el7_5.1.x86_64 (rhel-7-server-rhvh-4-rpms)
               libgomp = 4.8.2-16.el7_5
               libgomp = 4.8.5-28.el7_5.1
           Available: libgomp-4.8.5-36.el7.x86_64 (rhel-7-server-rhvh-4-rpms)
               libgomp = 4.8.2-16.el7
               libgomp = 4.8.5-36.el7
**********************************************************************
yum can be configured to try to resolve such errors by temporarily enabling
disabled repos and searching for missing dependencies.
To enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d/search-disabled-repos.conf
**********************************************************************

Error: Package: gcc-4.8.5-36.el7.x86_64 (rhel-7-server-rhvh-4-rpms)
           Requires: libgomp = 4.8.5-36.el7
           Installed: libgomp-4.8.5-36.el7_6.1.x86_64 (installed)
               libgomp = 4.8.2-16.el7_6
               libgomp = 4.8.5-36.el7_6.1
           Available: libgomp-4.8.5-16.el7_4.1.x86_64 (rhel-7-server-rhvh-4-rpms)
               libgomp = 4.8.2-16.el7_4
               libgomp = 4.8.5-16.el7_4.1
           Available: libgomp-4.8.5-16.el7_4.2.x86_64 (rhel-7-server-rhvh-4-rpms)
               libgomp = 4.8.2-16.el7_4
               libgomp = 4.8.5-16.el7_4.2
           Available: libgomp-4.8.5-28.el7.x86_64 (rhel-7-server-rhvh-4-rpms)
               libgomp = 4.8.2-16.el7
               libgomp = 4.8.5-28.el7
           Available: libgomp-4.8.5-28.el7_5.1.x86_64 (rhel-7-server-rhvh-4-rpms)
               libgomp = 4.8.2-16.el7_5
               libgomp = 4.8.5-28.el7_5.1
           Available: libgomp-4.8.5-36.el7.x86_64 (rhel-7-server-rhvh-4-rpms)
               libgomp = 4.8.2-16.el7
               libgomp = 4.8.5-36.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Uploading Enabled Repositories Report


Version-Release number of selected component (if applicable):
RHVH-4.3-20190305.0-RHVH-x86_64-dvd1.iso
cockpit-dashboard-176-4.el7.x86_64
cockpit-176-4.el7.x86_64
cockpit-system-176-4.el7.noarch
cockpit-ws-176-4.el7.x86_64
cockpit-machines-ovirt-176-4.el7.noarch
cockpit-ovirt-dashboard-0.12.4-1.el7ev.noarch
cockpit-bridge-176-4.el7.x86_64
cockpit-storaged-176-4.el7.noarch
imgbased-1.1.5-0.1.el7ev.noarch
subscription-manager-1.21.10-3.el7_6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Clean install RHVH-4.3-20190305.0-RHVH-x86_64-dvd1.iso
2. Login to cockpit with root account
3. Subscribe to RHVH product, and enable rhel-7-server-rhvh-4*
4. Yum install systemtap via CLI


Actual results:
Failed dependencies occur during install systemtap package.

Expected results:
Package systemtap can be installed successfully.


Additional info:


Note You need to log in before you can comment on or make changes to this bug.