Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1685006 - Should set correct empty state message for Resource Quotas
Summary: Should set correct empty state message for Resource Quotas
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-04 06:38 UTC by Yadan Pei
Modified: 2019-03-12 14:27 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-11 17:02:01 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Yadan Pei 2019-03-04 06:38:22 UTC
Description of problem:
When user don't have any projects, wrong message is shown on Resource Quotas page

Version-Release number of selected component (if applicable):
clusterversion: 4.0.0-0.nightly-2019-03-04-033148
console commit: d10fb8b637562015a0c704e72855e2d0c318783c

How reproducible:
Always

Steps to Reproduce:
1. user without any projects logins to cluster console
2. visit Administration -> Resource Quota page


Actual results:
2. Errors are shown:
resourcequotas is forbidden: User "ui1" cannot list resource "resourcequotas" in API group "" in the namespace "default"

Expected results:
2. Since user don't have any projects, we should print correct message "No Resource Quotas found"

Additional info:

Comment 1 Samuel Padgett 2019-03-04 14:14:13 UTC
https://github.com/openshift/console/pull/1250

Comment 2 Yadan Pei 2019-03-11 06:58:49 UTC
1. user without any projects logins to cluster console
2. visit Administration -> Resource Quota page, now it shows "No Resource Quotas Found"


Verified on 
$ oc image info registry.svc.ci.openshift.org/ocp/4.0-2019-03-10-103624@sha256:34de36b056aa48451c74d8812543e81c081d688cdc1feee38f68b84de2385559 | grep commit
             io.openshift.build.commit.id=e9e6e216b078e86604ae41fdd37d3da2a0c59d8b


Note You need to log in before you can comment on or make changes to this bug.