Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1684808 - dark theme in Mate leads to unreadable text [NEEDINFO]
Summary: dark theme in Mate leads to unreadable text
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 30
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: BetaFreezeException, F30BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2019-03-02 17:40 UTC by satellitgo
Modified: 2019-03-11 15:33 UTC (History)
11 users (show)

Fixed In Version: anaconda-30.25.2-1 anaconda-30.25.3-2.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-07 16:45:26 UTC
fedora: needinfo? (anaconda-maint-list)


Attachments (Terms of Use)
almost unreadable text in liveinst (deleted)
2019-03-02 17:40 UTC, satellitgo
no flags Details
anconda-good (deleted)
2019-03-03 11:02 UTC, Wolfgang Ulbrich
no flags Details
anaconda-bad anaconda-30.25-2.fc30 (deleted)
2019-03-03 11:03 UTC, Wolfgang Ulbrich
no flags Details

Description satellitgo 2019-03-02 17:40:52 UTC
Created attachment 1540086 [details]
almost unreadable text in liveinst

Description of problem:
dark theme in Mate leads to unreadable text

Version-Release number of selected component (if applicable):

Fedora-MATE_Compiz-Live-x86_64-30-20190301.n.0.iso
How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
black text against dark blue background in installer

Expected results:
legible text in dark theme

Additional info:

Comment 1 Wolfgang Ulbrich 2019-03-02 17:55:37 UTC
There is nothing changed in mate defaults theme (BlueMenta).
Looks like that anaconda starts to hard coding background colors.

Comment 2 Wolfgang Ulbrich 2019-03-03 10:58:43 UTC
Using anaconda-30.23-1.fc30 from Fedora-Rawhide-20190217.n.0 https://kojipkgs.fedoraproject.org/compose/rawhide/Fedora-Rawhide-20190217.n.0/compose/Spins/x86_64/iso/Fedora-MATE_Compiz-Live-x86_64-Rawhide-20190217.n.0.iso
doesn't have the issue with blue bg everywhere in anaconda.
The problem starts with anaconda-30.25-2/1.fc30 from Fedora-30-20190220.n.0 https://kojipkgs.fedoraproject.org/compose/branched/Fedora-30-20190220.n.0/compose/Spins/x86_64/iso/Fedora-MATE_Compiz-Live-x86_64-30-20190220.n.0.iso
So, there must be a change from 30.23 to 30.24/25 in anaconda which causes the issue with MATEs default theme BlueMenta.

For the the record Mate spin use this theme since f18 for the spin and there was never a problem with anaconda installer.

Re-asign this to anaconda.

Comment 3 Wolfgang Ulbrich 2019-03-03 11:01:35 UTC
Dear anaconda devs,
what is change in anaconda after anaconda-30.23-1.fc30 which can cause this issue.
Can you please point me to anacondas git reprository, Than i can look for myself too.

Comment 4 Wolfgang Ulbrich 2019-03-03 11:02:47 UTC
Created attachment 1540270 [details]
anconda-good

Comment 5 Wolfgang Ulbrich 2019-03-03 11:03:48 UTC
Created attachment 1540271 [details]
anaconda-bad anaconda-30.25-2.fc30

Comment 6 Wolfgang Ulbrich 2019-03-03 11:51:28 UTC
Issue is caused by https://github.com/rhinstaller/anaconda/commit/3ea114e9e4a13eeb08016f1a43203d364768aa2d
Why you override theme_bg_color define from gtk themes with fedora blue color without changing font color?
I don't think that hard coding a very common define like theme_bg_color is really a good idea.

Comment 7 Wolfgang Ulbrich 2019-03-03 13:17:12 UTC
I did a pull request to fi the problem.
https://github.com/rhinstaller/anaconda/pull/1860

Comment 8 Fedora Blocker Bugs Application 2019-03-04 16:32:50 UTC
Proposed as a Freeze Exception for 30-beta by Fedora user satellit using the blocker tracking app because:

 non blocking spin; very hard to see installer text

Comment 10 Geoffrey Marr 2019-03-04 18:32:13 UTC
Discussed during the 2019-03-04 blocker review meeting: [1]

The decision to classify this bug as an "AcceptedFreezeException" was made as this bug makes it hard to read the installer in MATE and obviously cannot be fixed with an update.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2019-03-04/f30-blocker-review.2019-03-04-17.03.txt

Comment 12 Fedora Update System 2019-03-06 18:17:23 UTC
anaconda-30.25.3-2.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-66802096bb

Comment 13 Fedora Update System 2019-03-07 16:45:26 UTC
anaconda-30.25.3-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Wolfgang Ulbrich 2019-03-11 15:33:27 UTC
Problem is solved with Fedora-MATE_Compiz-Live-x86_64-30-20190309.n.0.iso

[liveuser@localhost-live ~]$ rpm -qa anaconda
anaconda-30.25.3-2.fc30.x86_64


Note You need to log in before you can comment on or make changes to this bug.