Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1684569 - Upgrade from 4.1 and 5 is broken
Summary: Upgrade from 4.1 and 5 is broken
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: 5
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Sanju
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-01 14:51 UTC by Znamensky Pavel
Modified: 2019-03-27 13:46 UTC (History)
2 users (show)

Fixed In Version: glusterfs-5.5
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-11 00:31:31 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)
logs on srv1 after upgrading and starting glusterfs (deleted)
2019-03-01 14:51 UTC, Znamensky Pavel
no flags Details
logs on srv2 after upgrading srv1 (deleted)
2019-03-01 14:52 UTC, Znamensky Pavel
no flags Details


Links
System ID Priority Status Summary Last Updated
Gluster.org Gerrit 22314 None Merged core: make compute_cksum function op_version compatible 2019-03-11 00:31:30 UTC

Description Znamensky Pavel 2019-03-01 14:51:45 UTC
Created attachment 1539843 [details]
logs on srv1 after upgrading and starting glusterfs

Description of problem:
Online upgrade for replicated volumes cause upgraded node to be in "Peer Rejected" state.

Version-Release number of selected component (if applicable):
From 4.1.7 to 5.4

How reproducible:
Always

Steps to Reproduce:
1. setup replicated volume on v4.1
2. kill all gluster* processes on the first node
3. upgrade rpms up to v5.4
4. start gluster* processes on the first node

Actual results:
Peer is being rejected. And cluster operates without upgraded node.

`gluster peer status` shows:
State: Peer Rejected (Connected)

Expected results:
Online upgrade should works without downtime

Additional info:
Please see logs file in the attachment.

Comment 1 Znamensky Pavel 2019-03-01 14:52:34 UTC
Created attachment 1539845 [details]
logs on srv2 after upgrading srv1

Comment 2 Sanju 2019-03-05 15:46:23 UTC
upstream patch: https://review.gluster.org/#/c/glusterfs/+/22297/

Comment 3 Worker Ant 2019-03-07 06:29:59 UTC
REVIEW: https://review.gluster.org/22314 (core: make compute_cksum function op_version compatible) posted (#1) for review on release-5 by Sanju Rakonde

Comment 4 Worker Ant 2019-03-11 00:31:31 UTC
REVIEW: https://review.gluster.org/22314 (core: make compute_cksum function op_version compatible) merged (#5) on release-5 by Shyamsundar Ranganathan

Comment 5 Shyamsundar 2019-03-27 13:46:38 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.5, please open a new bug report.

glusterfs-5.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-March/000119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.