Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1684500 - compiler errors building qemu against glusterfs-6.0-0.1.rc0.fc30
Summary: compiler errors building qemu against glusterfs-6.0-0.1.rc0.fc30
Keywords:
Status: CLOSED DUPLICATE of bug 1684298
Alias: None
Product: Fedora
Classification: Fedora
Component: qemu
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fedora Virtualization Maintainers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1684298
Blocks: 1684496
TreeView+ depends on / blocked
 
Reported: 2019-03-01 11:48 UTC by Kaleb KEITHLEY
Modified: 2019-03-20 23:37 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1684298
Environment:
Last Closed: 2019-03-20 23:37:02 UTC


Attachments (Terms of Use)

Description Kaleb KEITHLEY 2019-03-01 11:48:22 UTC
+++ This bug was initially created as a clone of Bug #1684298 +++

qemu fails to rebuild in rawhide, seems like glusterfs related issues, using 6.0-0.1.rc0.fc31

https://koji.fedoraproject.org/koji/taskinfo?taskID=33109555
https://kojipkgs.fedoraproject.org//work/tasks/9555/33109555/build.log

A few example errors below. Any idea what's going on here?

BUILDSTDERR: /builddir/build/BUILD/qemu-3.1.0/block/gluster.c: In function 'qemu_gluster_co_pwrite_zeroes':
BUILDSTDERR: /builddir/build/BUILD/qemu-3.1.0/block/gluster.c:994:52: warning: passing argument 4 of 'glfs_zerofill_async' from incompatible pointer type [-Wincompatible-pointer-types]
BUILDSTDERR:   994 |     ret = glfs_zerofill_async(s->fd, offset, size, gluster_finish_aiocb, &acb);
BUILDSTDERR:       |                                                    ^~~~~~~~~~~~~~~~~~~~
BUILDSTDERR:       |                                                    |
BUILDSTDERR:       |                                                    void (*)(struct glfs_fd *, ssize_t,  void *) {aka void (*)(struct glfs_fd *, long int,  void *)}
BUILDSTDERR: In file included from /builddir/build/BUILD/qemu-3.1.0/block/gluster.c:12:
BUILDSTDERR: /usr/include/glusterfs/api/glfs.h:993:73: note: expected 'glfs_io_cbk' {aka 'void (*)(struct glfs_fd *, long int,  struct glfs_stat *, struct glfs_stat *, void *)'} but argument is of type 'void (*)(struct glfs_fd *, ssize_t,  void *)' {aka 'void (*)(struct glfs_fd *, long int,  void *)'}
BUILDSTDERR:   993 | glfs_zerofill_async(glfs_fd_t *fd, off_t length, off_t len, glfs_io_cbk fn,
BUILDSTDERR:       |                                                             ~~~~~~~~~~~~^~
BUILDSTDERR: /builddir/build/BUILD/qemu-3.1.0/block/gluster.c: In function 'qemu_gluster_do_truncate':
BUILDSTDERR: /builddir/build/BUILD/qemu-3.1.0/block/gluster.c:1035:13: error: too few arguments to function 'glfs_ftruncate'
BUILDSTDERR:  1035 |         if (glfs_ftruncate(fd, offset)) {

--- Additional comment from Kaleb KEITHLEY on 2019-03-01 11:44:13 UTC ---

Nope. It's not a bug in glusterfs.

qemu needs to fix its call to glfs_ftruncate() to add the missing parameter.

GlusterFS uses versioned symbols in libgfapi.  Old programs compiled & linked against an older libgfapi.so will continue to work with a new libgfapi.so, but when (re)compiling with the new library you have to keep up with the API changes.

I will be closing this aa NOTABUG in a few days.

Comment 1 Cole Robinson 2019-03-20 23:37:02 UTC

*** This bug has been marked as a duplicate of bug 1684298 ***


Note You need to log in before you can comment on or make changes to this bug.