Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1684469 - Can't install java-1.8.0-openjdk - missing pcsc-lite-devel [NEEDINFO]
Summary: Can't install java-1.8.0-openjdk - missing pcsc-lite-devel
Keywords:
Status: CLOSED DUPLICATE of bug 1684077
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: java-1.8.0-openjdk
Version: 7.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Deepak Bhole
QA Contact: OpenJDK QA
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-01 10:48 UTC by Lucie Vrtelova
Modified: 2019-03-01 12:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-01 11:00:46 UTC
Target Upstream Version:
jhutar: needinfo? (ogajduse)


Attachments (Terms of Use)

Description Lucie Vrtelova 2019-03-01 10:48:38 UTC
Description of problem:
Can't install java-1.8.0-openjdk - missing pcsc-lite-devel

Version-Release number of selected component (if applicable):
java-1.8.0-openjdk-headless-1.8.0.201.b09-0.el7_6

How reproducible:
always

Steps to Reproduce:
1. yum install java-1.8.0-openjdk-headless-1.8.0.201.b09-0.el7_6

Actual results:
Package is not installed.

Log:
------
Loaded plugins: product-id, search-disabled-repos, subscription-manager
Sat6-CI_Red_Hat_Satellite_6_5_Composes_Satellite_6_5_RHEL7                                             | 2.5 kB  00:00:00     
Sat6-CI_Red_Hat_Satellite_6_5_Composes_Satellite_Tools_6_5_RHEL7                                       | 2.1 kB  00:00:00     
Resolving Dependencies
--> Running transaction check
---> Package java-1.8.0-openjdk-headless.x86_64 1:1.8.0.191.b12-1.el7_6 will be updated
---> Package java-1.8.0-openjdk-headless.x86_64 1:1.8.0.201.b09-0.el7_6 will be an update
--> Processing Dependency: cups-libs(x86-64) for package: 1:java-1.8.0-openjdk-headless-1.8.0.201.b09-0.el7_6.x86_64
--> Processing Dependency: pcsc-lite-devel(x86-64) for package: 1:java-1.8.0-openjdk-headless-1.8.0.201.b09-0.el7_6.x86_64
--> Running transaction check
---> Package cups-libs.x86_64 1:1.6.3-35.el7 will be installed
--> Processing Dependency: libavahi-client.so.3()(64bit) for package: 1:cups-libs-1.6.3-35.el7.x86_64
--> Processing Dependency: libavahi-common.so.3()(64bit) for package: 1:cups-libs-1.6.3-35.el7.x86_64
---> Package java-1.8.0-openjdk-headless.x86_64 1:1.8.0.201.b09-0.el7_6 will be an update
--> Processing Dependency: pcsc-lite-devel(x86-64) for package: 1:java-1.8.0-openjdk-headless-1.8.0.201.b09-0.el7_6.x86_64
--> Running transaction check
---> Package avahi-libs.x86_64 0:0.6.31-19.el7 will be installed
---> Package java-1.8.0-openjdk-headless.x86_64 1:1.8.0.201.b09-0.el7_6 will be an update
--> Processing Dependency: pcsc-lite-devel(x86-64) for package: 1:java-1.8.0-openjdk-headless-1.8.0.201.b09-0.el7_6.x86_64
--> Finished Dependency Resolution
Error: Package: 1:java-1.8.0-openjdk-headless-1.8.0.201.b09-0.el7_6.x86_64 (rhel-7-server-rpms)
           Requires: pcsc-lite-devel(x86-64)
**********************************************************************
yum can be configured to try to resolve such errors by temporarily enabling
disabled repos and searching for missing dependencies.
To enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d/search-disabled-repos.conf
**********************************************************************

Error: Package: 1:java-1.8.0-openjdk-headless-1.8.0.201.b09-0.el7_6.x86_64 (rhel-7-server-rpms)
           Requires: pcsc-lite-devel(x86-64)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Expected results:
Package is installed.

Additional info:
Previous version java-1.8.0-openjdk-headless-1.8.0.191.b12-1.el7_6 can be installed without problems.

Comment 3 jiri vanek 2019-03-01 11:00:46 UTC
Considering how long the issue was in 7.7, please consider inclusion of future rhels to your workflow.

*** This bug has been marked as a duplicate of bug 1684077 ***


Note You need to log in before you can comment on or make changes to this bug.