Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1684337 - Network doesn't work well in win2019 guest when booting qemu with 4 queues and 1 vector
Summary: Network doesn't work well in win2019 guest when booting qemu with 4 queues an...
Keywords:
Status: CLOSED DUPLICATE of bug 1666940
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: virtio-win
Version: 8.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Virtualization Maintenance
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-01 01:53 UTC by Lei Yang
Modified: 2019-03-01 09:11 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-01 09:11:17 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description Lei Yang 2019-03-01 01:53:18 UTC
Description of problem:
Test win2019 guest booting with different vectors. Guest network works well with vectors 0/2/3/4/5, however network is down when vectors=1.

Version-Release number of selected component (if applicable):
kernel-4.18.0-71.el8.x86_64
virtio-win-1.9.7-3.el8.noarch
qemu-kvm-2.12.0-63.module+el8+2833+c7d6d092.x86_64

How reproducible:
4/4

Steps to Reproduce:
1.Boot win2019 guest with queues=4 and vecttors=1.qemu prompts errors.

/usr/libexec/qemu-kvm -name Win2019 \
-M q35,kernel-irqchip=split -m 4g \
-cpu EPYC,hv_stimer,hv_synic,hv_time,hv_relaxed,hv_vpindex,hv_spinlocks=0xfff,hv_vapic,hv_reset,hv_crash \
-device intel-iommu,intremap=true,caching-mode=true \
-smp 4,sockets=1,cores=4,threads=1 \
-device pcie-root-port,id=root.1,chassis=1 \
-device pcie-root-port,id=root.2,chassis=2 \
-blockdev driver=file,cache.direct=off,cache.no-flush=on,filename=/home/win2019.qcow2,node-name=my_file \
-blockdev driver=qcow2,node-name=my,file=my_file \
-device virtio-blk-pci,drive=my,id=virtio-blk0,bus=root.1 \
-drive id=drive_cd1,if=none,snapshot=off,aio=native,cache=none,media=cdrom,file=/home/en_windows_server_2019_x64_dvd_4cb967d8.iso \
-device ide-cd,id=cd1,drive=drive_cd1,bus=ide.0,unit=0 \
-drive id=drive_winutils,if=none,snapshot=off,aio=native,cache=none,media=cdrom,file=/usr/share/virtio-win/virtio-win-1.9.7.iso \
-device ide-cd,id=winutils,drive=drive_winutils,bus=ide.1,unit=0 \
-vnc :3 \
-vga qxl \
-monitor stdio \
-usb -device usb-tablet \
-boot menu=on \
-netdev tap,id=hostnet1,vhost=on,queues=4 \
-device virtio-net-pci,indirect_desc=off,netdev=hostnet1,id=net1,mac=18:66:da:5f:d1:02,bus=root.2,vectors=1,mq=on \

(qemu) qemu-kvm: unable to start vhost net: 14: falling back on userspace virtio
qemu-kvm: warning: guest updated active QH
qemu-kvm: warning: guest updated active QH

2.Check guest Network status-->Not connected

Actual results:
Network is down.

Expected results:
Network is up.

Additional info:
1. Fast train bug:
Bug 1684063 - Network doesn't work well in win2019 guest when booting qemu with 4 queues and 1 vector

Comment 1 Pei Zhang 2019-03-01 09:11:17 UTC

*** This bug has been marked as a duplicate of bug 1666940 ***


Note You need to log in before you can comment on or make changes to this bug.