Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1684318 - Satellite wrongly considers an empty ISO repo as invalid
Summary: Satellite wrongly considers an empty ISO repo as invalid
Keywords:
Status: NEW
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Repositories
Version: 6.4.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: vijsingh
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-01 01:05 UTC by Rohan McGovern
Modified: 2019-03-05 04:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Target Upstream Version:


Attachments (Terms of Use)

Description Rohan McGovern 2019-03-01 01:05:58 UTC
When a user enables an ISO repo, and the repo contains 0 files, it seems that Satellite will produce an error.  This doesn't make sense, as an empty repository is still valid.

For example, this path on CDN is a valid ISO repo but empty at time of writing: https://cdn.redhat.com/content/dist/rhel/server/7/7Server/x86_64/dotnet/1/iso

Thus it contains only a 0-byte PULP_MANIFEST file.

Users reported that attempting to enable the repo produces error message:

  The path /content/dist/rhel/server/7/7Server/x86_64/dotnet/1/iso does not seem to be a valid repository


Note You need to log in before you can comment on or make changes to this bug.