Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1683955 - [UI] - "Host has no default route." exclamation icon consistently shown for all hosts under general sub tab
Summary: [UI] - "Host has no default route." exclamation icon consistently shown for a...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network
Version: 4.3.0
Hardware: x86_64
OS: Linux
unspecified
medium vote
Target Milestone: ovirt-4.3.2
: ---
Assignee: eraviv
QA Contact: Michael Burman
URL:
Whiteboard:
: 1689172 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-28 08:11 UTC by Michael Burman
Modified: 2019-03-19 10:05 UTC (History)
3 users (show)

Fixed In Version: ovirt-engine-4.3.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-19 10:05:20 UTC
oVirt Team: Network
pm-rhel: ovirt-4.3+
pm-rhel: blocker+
dholler: devel_ack+
dholler: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 98104 master MERGED webadmin: alert default route network missing on host 2019-03-01 08:10:17 UTC

Description Michael Burman 2019-02-28 08:11:44 UTC
Description of problem:
[UI] - "Host has no default route." exclamation icon consistently shown for all hosts under general sub tab.

New regression, possible caused by latest changes in this area.
All hosts now reported in the engine UI as they missing default route on the host. The exclamation icon show all the time that host has no default route, but it has. This relevant for ipv4 and ipv6 default routes, in all cases, engine report host has no default route.

Version-Release number of selected component (if applicable):
4.3.1.1-0.1.el7

How reproducible:
100%

Steps to Reproduce:
1. Add host to RHV 
2. Go to General sub tab

Actual results:
"Host has no default route." exclamation icon consistently shown

Expected results:
This exclamation icon should appear only when host has o default route

Comment 1 Dominik Holler 2019-02-28 09:41:49 UTC
Looks like a clean negation error.
The opposite value of the shown value should be correct.

Comment 2 RHEL Product and Program Management 2019-02-28 10:05:51 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 3 Michael Burman 2019-03-06 08:17:48 UTC
Verified on - rhvm-4.3.2-0.1.el7.noarch

Comment 4 Christoph 2019-03-17 10:46:48 UTC
*** Bug 1689172 has been marked as a duplicate of this bug. ***

Comment 5 Sandro Bonazzola 2019-03-19 10:05:20 UTC
This bugzilla is included in oVirt 4.3.2 release, published on March 19th 2019.

Since the problem described in this bug report should be
resolved in oVirt 4.3.2 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.