Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 168312 - up2date config file is not ignored in rpm -V
Summary: up2date config file is not ignored in rpm -V
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bryan Kearney
QA Contact: Beth Nackashi
URL:
Whiteboard:
: 179896 (view as bug list)
Depends On:
Blocks: RHEL3U8CanFix
TreeView+ depends on / blocked
 
Reported: 2005-09-14 20:29 UTC by Beth Nackashi
Modified: 2013-01-10 08:50 UTC (History)
1 user (show)

Fixed In Version: RHBA-2006-0465
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-07-20 15:14:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0465 normal SHIPPED_LIVE up2date bug fix update 2006-07-19 20:50:00 UTC

Description Beth Nackashi 2005-09-14 20:29:21 UTC
Description of problem:
up2date config file is subject to size/MD5/timestamp changes so it should be
ignored by rpm -V

Version-Release number of selected component (if applicable):
all

How reproducible:


Steps to Reproduce:
1.  rpm -V up2date
  
Actual results:
failures will likely be due to MD5, size, or timestamp change(s) in config file

Expected results:
no failures due to config file changes

Additional info:
Fix might be something like this?
%config(missingok,noreplace) %verify(not md5 size mtime) /etc/sysconfig/rhn/up2date

not sure .....

Comment 1 Adrian Likins 2005-10-05 16:55:29 UTC
hmm, maybe

Comment 3 Fanny Augustin 2006-04-11 00:16:26 UTC
Blocking rhnupr4u4 and rhnupr3u8 to track the progress of the release

Comment 4 Fanny Augustin 2006-04-13 19:15:23 UTC
Moving bugs to the CanFix List

Comment 7 Fanny Augustin 2006-05-09 19:37:45 UTC
This bug has been fixed in this release

Comment 8 James Bowes 2006-05-09 20:20:24 UTC
*** Bug 179896 has been marked as a duplicate of this bug. ***

Comment 9 Beth Nackashi 2006-05-15 19:17:18 UTC
To view the spec file:
1- copy the source rpm onto the client
2- rpm2cpio up2date-x.x.xx-x.src.rpm |cpio -i -d
3- open up2date.spec


Comment 10 Beth Nackashi 2006-05-15 19:40:46 UTC
Package verified:
up2date-4.4.69-8.src.rpm

The following lines were added to up2date.spec to fix this bug:
%config(noreplace) %verify(not md5 size mtime mode) /etc/sysconfig/rhn/up2date
%config(noreplace) %verify(not md5 size mtime) /etc/sysconfig/rhn/up2date-uuid

I have seen a mode failure on my x86_64 box, so I am recommending adding mode to
the up2date-uuid list of excludes.

[root@bnackash-64 tmp]# rpm -V up2date
.M...... c /etc/sysconfig/rhn/up2date-uuid


Comment 11 Beth Nackashi 2006-06-01 14:48:23 UTC
latest up2date and rhnlib packages:

/dist/3.0E-U8/up2date/4.4.69-10
/dist/3.0E-U8/rhnlib/1.8.7-3

Comment 12 Beth Nackashi 2006-06-01 17:11:52 UTC
mode has been added to the up2date-uuid list of excludes:

%config(noreplace) %verify(not md5 size mtime mode) /etc/sysconfig/rhn/up2date
%config(noreplace) %verify(not md5 size mtime mode) /etc/sysconfig/rhn/up2date-uuid


Comment 14 Red Hat Bugzilla 2006-07-20 15:14:33 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0465.html



Note You need to log in before you can comment on or make changes to this bug.