Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 168118 - Missing support for "forcequotacheck"
Summary: Missing support for "forcequotacheck"
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks: FC5Target 150857
TreeView+ depends on / blocked
 
Reported: 2005-09-12 17:29 UTC by Bill Nottingham
Modified: 2014-03-17 02:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-04-10 22:50:56 UTC


Attachments (Terms of Use)

Description Bill Nottingham 2005-09-12 17:29:54 UTC
+++ This bug was initially created as a clone of Bug #150857 +++

Description of problem:
initscripts does not support a straight forward mechanism to run a
later quotacheck on even clean partitions.

Version-Release number of selected component (if applicable):
initscripts-7.93.11.EL-1

How reproducible:
Always

Steps to Reproduce:
1. install RHEL4
2. create some new partitions
3. mount some new partitions
4. decide to use quota on this (now already used) new partitions
5. extend entries in /etc/fstab
6. reboot
    

Actual Results:  Got quota error message, systen can't start quota
because of missing quota files

Expected Results:  rc.sysinit is more smarter, e.g.

1) support file /forcequotacheck

2) check on partitions with quota enabled in /etc/fstab for the quota
files and force quotacheck if not existing (so called initialize)

Additional info:

-- Additional comment from tometzky@batory.org.pl on 2005-05-31 08:11 EST --
Created an attachment (id=114987)
/forcequotacheck support in rc.sysinit

This is a proposed solution to this - a patch to /etc/rc.sysinit from Fedora
Core 3.

There is no easy way to enable quotas or force quotacheck because of corrupted
quota files so I think support for /forcequotacheck is needed. It could now
only be done in single user mode - quotacheck remount filesystems readonly,
which is impossible on life system - especially on "/" or "/var". Very hard for
unskilled administrator.

It could be possible to add support for checking quotas of some, not all
filesystems - but I think it is not needed. Also there could be possible to
force quotacheck if a filesystem have quotas enables but no quota files - but
this could trigger everytime for example on XSF filesystem, which does not need
quota files.

-- Additional comment from milan.kerslager@pslib.cz on 2005-09-11 19:09 EST --
qutacheck should be run automagically when fsck fix a bug on FS because there
will be surely inconsistence (as FS has been modified and quota entries did not).

-- Additional comment from milan.kerslager@pslib.cz on 2005-09-11 19:15 EST --
...my users always complaining after unexpected crashes when fsck has been
succesfully auto-run (and FS has been succesfully fixed). As I have 700+ users
and low quota, some of them are sometimes over the quota even they have empty
homedir and I have to run quotacheck manually in singleuser mode (and walk to
the server's room).

Comment 1 Miloslav Trmač 2006-03-27 22:30:55 UTC
The code to run quotacheck after fsck fixes the FS is present, it just wasn't
triggered due to a bug, now fixed in CVS.

Comment 2 Miloslav Trmač 2006-04-10 22:50:56 UTC
Applied in initscripts-8.32-1.  Thanks!


Note You need to log in before you can comment on or make changes to this bug.