Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 167855 - Error informing the kernel about modifications to partition /dev/sda5 - Device or resource
Summary: Error informing the kernel about modifications to partition /dev/sda5 - Devic...
Keywords:
Status: CLOSED DUPLICATE of bug 160693
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-09-08 21:28 UTC by Michael McMahon
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-09 14:47:32 UTC


Attachments (Terms of Use)
anacdump (deleted)
2005-09-08 21:37 UTC, Michael McMahon
no flags Details

Description Michael McMahon 2005-09-08 21:28:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Description of problem:
I recieved the following error "Error informing the kernel about modifications to partition /dev/sda5 - Device or resource" while installing fedora 4 on a new Dell Deminsion 9100 (DIM 9100 630 3.0GHz, 512MB Dual Channel DDR2 400MHz (2x256) Memory, 160GB 7200rpm SATA Hard Drive, 256MB nVidia Ge Force 6800)with the request that I copy the anacdump to bugzilla (will attach). 

It occured during a text install - graphic install froze as soon as graphics loaded and when installed with the boot line 'linux nofb' I recieved the error along the lines of 'unsupported video mode' at the same stage in the process - I don't know if that had anything to do with the error.

The command line I finally installed from was:

linux jfs nofb ide=nodma

hope this helps. 

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:

* had unresolved dependencies, resolved.
* moving (1) to step confirminstall
* discNums is [1]
* don't have 2
* moving (1) to step install
* id.methodstr = cdrom://hda:/mnt/source 0
* moving (1) to step enablefilesystems
* parted exception: Error: Error informing the kernel about modifications to partition /dev/sda5 - Device or resource busy.  This means Linux won't know about any changes you made to /dev/sda5 until you reboot - so you shouldn't mount it or use it in any way before rebooting.


/tmp/lvmout:
  No volume groups found
apable devices
    Wiping internal VG cache
    Finding all volume groups
  No volume groups found
  Reading all physical volumes.  This may take a while...
cal volumes.  This may take a while...

Comment 1 Michael McMahon 2005-09-08 21:37:01 UTC
Created attachment 118612 [details]
anacdump

This the anacdump created by the error message with a request that it be
submitted to bugzilla.

Comment 2 Michael McMahon 2005-09-09 14:18:59 UTC
I have reinstalled using ext3 instead of jfs on /dev/sda5 and this seems to have
solved the problem. 

small correction to the info above - the boot line should have read 

linux jfs nofb ide=nodma text

Comment 3 Chris Lumens 2005-09-09 14:47:32 UTC
It probably should have worked regardless of what filesystem you used on the
second attempt as long as you provided the same partitioning information.

*** This bug has been marked as a duplicate of 160693 ***


Note You need to log in before you can comment on or make changes to this bug.