Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 167822 - patch produces "getfilecon: No such file or directory" errors
Summary: patch produces "getfilecon: No such file or directory" errors
Keywords:
Status: CLOSED DUPLICATE of bug 165799
Alias: None
Product: Fedora
Classification: Fedora
Component: patch
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-09-08 15:28 UTC by Nalin Dahyabhai
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-12-20 14:55:24 UTC


Attachments (Terms of Use)

Description Nalin Dahyabhai 2005-09-08 15:28:12 UTC
Description of problem:
When applying a patch, patch seems to always be printing an "getfilecon: No such
file or directory" error.

Version-Release number of selected component (if applicable):
2.5.4-27

How reproducible:
Always

Steps to Reproduce:
1. Check out a package from Fedora CVS.
2. Run "make prep".
  
Actual results:
The patch is applied, but a "getfilecon: No such file or directory" error is
printed.  Example snippet:
   + echo 'Patch #1 (patch-2.5-stderr.patch):'
   Patch #1 (patch-2.5-stderr.patch):
   + patch -p1 -b --suffix .stderr -s
   getfilecon: No such file or directory
   + echo 'Patch #2 (patch-2.5.4-suffix.patch):'
   Patch #2 (patch-2.5.4-suffix.patch):
   + patch -p1 -b --suffix .suffix -s
   getfilecon: No such file or directory
   + echo 'Patch #3 (patch-2.5.4-sigsegv.patch):'
   Patch #3 (patch-2.5.4-sigsegv.patch):
   + patch -p1 -b --suffix .sigsegv -s
   getfilecon: No such file or directory
   getfilecon: No such file or directory
   getfilecon: No such file or directory
   + echo 'Patch #4 (patch-2.5.4-ifdef.patch):'
   Patch #4 (patch-2.5.4-ifdef.patch):
   + patch -p1 -b --suffix .ifdef -s
   getfilecon: No such file or directory
   + echo 'Patch #5 (patch-2.5.4-program_name.patch):'

Expected results:
Patch is applied, no error message.

Additional info:
I think that this is happening in copy_filecon(), when it attempts to get the
context of the "to" file, before the "from" file has been rename()d, because the
"to" file doesn't exist yet.

Comment 1 Tim Waugh 2005-12-20 14:55:24 UTC
Caused by bad fix to bug #165799, since reverted.

*** This bug has been marked as a duplicate of 165799 ***


Note You need to log in before you can comment on or make changes to this bug.