Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 167690 - Mini-commander is no response to keyboard when using scim
Summary: Mini-commander is no response to keyboard when using scim
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libX11
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC5Target SCIM
TreeView+ depends on / blocked
 
Reported: 2005-09-07 08:47 UTC by Qingyu Wang
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-27 11:18:14 UTC


Attachments (Terms of Use)

Description Qingyu Wang 2005-09-07 08:47:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; zh-CN; rv:1.7.10) Gecko/20050719 Red Hat/1.0.6-1.4.1 Firefox/1.0.6

Description of problem:
I add a "Mini-Commander" in my Panel. Once I invoke scim in the "Mini-Commander" I can't input anything, even can't input English letters. Also, I can't switch off scim by keyboard. It seems that it is the same bug as what in https://bugs.freedesktop.org/show_bug.cgi?id=2006, and it is true that when I use XIM "Mini-Commander" can't recieve any key event. Yet the same problem didn't happen when I use IIIMF. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. add a "Mini-Commander" to Panel from Panel menu
2. activate scim 
3. try to input anyting in "Mini-Commander" and you will find no response at all
4. try to switch off scim by keyboard "Ctrl+Space", failed
  

Actual Results:  "Mini-Commander" is no response to keyboard input

Expected Results:  "Mini-Commander" recieves keyboard input normally

Additional info:

Comment 1 Qingyu Wang 2005-09-07 09:27:29 UTC
Version-Release number of selected component:
scim-1.4.2-0

Comment 2 Leon Ho 2005-09-08 01:28:47 UTC
Thanks Qingyu for the report. Jens will look into this bug.

Comment 3 Warren Togami 2005-09-08 11:26:21 UTC
The next logical step is to rebuild xorg-x11 using that patch and test if it works.

Comment 4 Jens Petersen 2005-09-28 08:43:01 UTC
I can't reproduce this in FC devel.

Comment 5 Jens Petersen 2005-09-28 09:22:53 UTC
I tested a little more:

So with gtk immodule, I can input ascii when scim is turned off and on.
When I switch to xim I can still input until turning on scim, when
input is locked until I turn it off from the scim menu again.

Comment 6 Qingyu Wang 2005-11-15 07:07:51 UTC
With more test I find this bug happens when I unset the env variable
GTK_IM_MODULE=scim. But with this variable setting, there is still a similar
bug.  In the Mini-Commander, scim can't be invoked and deactivated by
[Ctrl]+[Space] but just can be invoked by mouse from menu. And once I invoke
scim in the "Mini-Commander" I can't input Chinese with scim. I can just input
English letters.

Comment 7 Jens Petersen 2005-12-20 08:43:05 UTC
Moving to FC5Target since only happens under xim which is not
used for the gnome-panel.

Comment 8 Jens Petersen 2005-12-20 09:17:33 UTC
Reassigning to libX11 owner based on upstream bug in original report.

Comment 9 Mike A. Harris 2006-01-27 11:18:14 UTC
The bug was fixed in CVS head, in March 2005, so it should be present in
X11R7, which is in rawhide now.

 ------- Additional comment #7  from Alan Coopersmith on 2005-03-07 18:54 
[reply] -------

Patch makes sense to me, so I went ahead and committed it to head:

CVSROOT:	/cvs/xorg
Module name:	xc
Changes by:	alanc@gabe.freedesktop.org	05/03/07 18:53:36

Log message:
  2005-03-07  Alan Coopersmith  <alan.coopersmith@sun.com>
  
  	* xc/lib/X11/imEvToWire.c:
  	Bugzilla Bug 2006 (https://bugs.freedesktop.org/show_bug.cgi?id=2006)
  	Patch #2031 (https://bugs.freedesktop.org/attachment.cgi?id=2031)
  	XEmbed client doesn't receive key events from XIM: Use | to set a bit,
  	not &.   Patch by Hidetoshi Tajima <hidetoshi.tajima@sun.com>.

Modified files:
      ./:
        ChangeLog 
      xc/lib/X11/:
        imEvToWire.c 
  
  Revision      Changes    Path
  1.803         +9 -1      xc/ChangeLog
  1.3           +1 -1      xc/lib/X11/imEvToWire.c


Note You need to log in before you can comment on or make changes to this bug.