Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 167440 - fdisk on /dev/mapper/xxxx entries gives error when re-reading modified partition table
Summary: fdisk on /dev/mapper/xxxx entries gives error when re-reading modified partit...
Keywords:
Status: CLOSED DUPLICATE of bug 160277
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: device-mapper-multipath
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Alasdair Kergon
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-09-02 17:35 UTC by Stoo Davies
Modified: 2010-01-12 02:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-03 22:17:19 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Stoo Davies 2005-09-02 17:35:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.9) Gecko/20050715 Firefox/1.0.5

Description of problem:
I am doing some initial testing on RHES4-U2 beta release, in particular I'm testing dm-multipath/multipath-tools with a 3PAR storage array.
 
When trying to partition the /dev/mapper/xxxxx devices fdisk gives the following error...
 
-----------------------------------------------------------------
Command (m for help): w
The partition table has been altered!
 
Calling ioctl() to re-read partition table.
 
WARNING: Re-reading the partition table failed with error 22: Invalid argument.
The kernel still uses the old table.
The new table will be used at the next reboot.
Syncing disks.
-----------------------------------------------------------------

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Setup a multipathed device with the multipath command
Run fdisk on the created disk device
Save out partition table


Actual Results:  Table was not re-read

Expected Results:  Table should of been re-read and used by the kernel

Additional info:

Comment 1 Alasdair Kergon 2005-10-03 22:17:19 UTC
The kernel can't use the partition tables on these devices.

Instead we run 'kpartx' to set them up from userspace using device-mapper.

*** This bug has been marked as a duplicate of 160277 ***


Note You need to log in before you can comment on or make changes to this bug.