Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 167383 - Embedded fonts are not used by default when AA is turned on
Summary: Embedded fonts are not used by default when AA is turned on
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: fontconfig
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Carl Worth
QA Contact:
URL:
Whiteboard:
Depends On: 176910
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-09-02 05:43 UTC by Leon Ho
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-31 19:17:57 UTC


Attachments (Terms of Use)
sample fonts.conf to disable the antialias for Japanese say (deleted)
2005-12-07 11:08 UTC, Akira TAGOH
no flags Details
Patch to change rh_prefer_bitmaps to embeddedbitmap (deleted)
2005-12-20 05:33 UTC, Tim Mayberry
no flags Details | Diff

Description Leon Ho 2005-09-02 05:43:40 UTC
Description of problem:
In the current version (rawhide) of fontconfig and libraries combinations, the
application will not use emdedded fonts in TTF anymore even if one is available.

Version-Release number of selected component (if applicable):
fontconfig-2.3.2-1

How reproducible:
everytime

Steps to Reproduce:
1. LANG=zh_TW.UTF-8 gedit
2. Check the font glyphs
compare with
1. gnome-font-properties
2. disable AA
3. gedit
  
Actual results:
Fonts are not embedded bitmap in the default font size

Expected results:
Fonts should be embedded bitmap in the default font size

Additional info:
FC4 is fine.
We have "rh_prefer_bitmaps" option in /etc/fonts/conf.d/50-no-hint-fonts.conf to
disable embedded bitmap for particular font. (Japanese is currently being
disabled on bitmap)

Comment 2 sangu 2005-12-02 10:59:42 UTC
Please See bug 164374


Comment 3 Akira TAGOH 2005-12-07 11:08:10 UTC
Created attachment 121966 [details]
sample fonts.conf to disable the antialias for Japanese say

Attached file is to disable the antialias for Japanese. it works for me after
put it as .fonts.conf under $HOME. for other languages which prefer the bitmap
font rather than the antialiased outline font, you need to modify the pixelsize
to something what these fonts actually supports. FYI.

Comment 4 Leon Ho 2005-12-08 18:21:51 UTC
In FC4, we can enable antialiasing outline font, but when the size of the glyphs
has the embedded bitmap font, we then use the bitmap glyph instead of the
outline glyph. This should be the behaviour.

Comment 5 Tim Mayberry 2005-12-20 05:33:09 UTC
Created attachment 122438 [details]
Patch to change rh_prefer_bitmaps to embeddedbitmap 

This patch changes all instances of rh_prefer_bitmaps to embeddedbitmap. It
also disables hinting and enables the embedded bitmap option for the 2 new
Chinese fonts. As mentioned in bug
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=164374 The embedded bitmap
directive AFAIK won't work until cairo is modified to support it. There patches
around such as this one
http://lists.freedesktop.org/archives/cairo/2005-September/005404.html to do
this but I'm yet to test them(soon hopefully).

Comment 6 Tim Mayberry 2005-12-23 06:30:07 UTC
Added dependance on bug #165939 because the fontconfig configuration files
currently alias AR PL ZenKai Uni as the default sans-serif font and it should be
AR PL ShanHeiSun Uni. It effects this bug because only AR PL ShanHeiSun Uni has
embedded bitmaps.

Comment 7 Leon Ho 2006-01-16 07:16:07 UTC
This is a major feature for Chinese for FC5 that has been tested for a while. It
would be helpful to include now before FC5 releases.

Comment 8 Christopher Aillon 2006-01-27 19:12:30 UTC
Carl, ping here.  There's a patch and it seems to be important for Chinese. 
Please comment on what we should do.  Thanks.

Comment 9 Tim Mayberry 2006-01-31 05:43:51 UTC
Both of the patches are obselete, the patches in bug 165939 included the fixes
for the fontconfig configuration side of the problem. This bug is still
dependant on getting the fontconfig "embeddedbitmap" option supported by cairo.
There is a patch for cairo that I found on the cairo mailinglist that is
attached to bug 176910 but I am waiting for feedback from Carl or others about
the patch. I think we could also consider patching Xft to support the
embeddedbitmap option if it doesn't already.


Note You need to log in before you can comment on or make changes to this bug.