Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 167363 - loadkeys in rc.sysinit is no longer non-UTF-8 safe
Summary: loadkeys in rc.sysinit is no longer non-UTF-8 safe
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
: 160039 (view as bug list)
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-09-01 21:23 UTC by Peter Bieringer
Modified: 2014-03-17 02:55 UTC (History)
2 users (show)

Fixed In Version: 8.44-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-10-05 16:48:32 UTC


Attachments (Terms of Use)

Description Peter Bieringer 2005-09-01 21:23:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
If system is in non-UTF-8 mode, loadkey still uses "-u" to load keymap. This will cause that e.g. German umlauts are displayed as two chars.

Version-Release number of selected component (if applicable):
initscripts-8.11.1-1

How reproducible:
Always

Steps to Reproduce:
1. enable non-UTF-8 mode in /etc/sysconfig/i18n (e.g. LANG=en_US)
2. reboot
3. use a German keyboard and type a German umlaut on a console
  

Actual Results:  Strange chars are displayed

Expected Results:  Germans umlauts are displayed

Additional info:

loadkey call in rc.sysinit unconditionally uses "-u" for unicode setup:

  loadkeys -u $KEYMAP < /dev/tty0 > /dev/tty0 2>/dev/null && \
     success $"Loading default keymap" || failure $"Loading default keymap"
  echo

That was not a good idea to use "-u" without checking whether system language is UTF-8.

A temporary fix is to remove "-u" on non-UTF-8 systems.

Comment 1 Miloslav Trmač 2005-09-27 14:02:20 UTC
*** Bug 160039 has been marked as a duplicate of this bug. ***

Comment 2 Bill Nottingham 2006-10-05 16:48:32 UTC
Fixed in 8.44-1, thanks!

Comment 3 Fedora Update System 2006-10-19 21:15:49 UTC
initscripts-8.31.6-1 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Comment 4 Fedora Update System 2006-10-26 17:44:51 UTC
initscripts-8.31.6-1 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.