Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1672818 (glusterfs-6.0) - GlusterFS 6.0 tracker
Summary: GlusterFS 6.0 tracker
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: glusterfs-6.0
Product: GlusterFS
Classification: Community
Component: core
Version: 6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1670718 1672318 1679892 1695416 1673972 1674364 1676356 1676429 1679275 1680585 1680586 1683574 1683880 1684029 1684385 1685771 1686364 1686875 1687672 1691616 1696147 1696513
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-06 00:56 UTC by Shyamsundar
Modified: 2019-04-08 02:42 UTC (History)
6 users (show)

Fixed In Version: glusterfs-6.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-19 14:48:45 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gluster.org Gerrit 22173 None Open api: Update all future API versions to rel-6 2019-02-08 15:48:07 UTC
Gluster.org Gerrit 22226 None Open doc: Added initial release notes for release-6 2019-02-22 04:13:16 UTC
Gluster.org Gerrit 22250 None Open doc: Update release notes for Samba integration 2019-03-12 20:57:27 UTC
Gluster.org Gerrit 22285 None Abandoned doc: update releasenote 2019-03-25 07:18:00 UTC
Gluster.org Gerrit 22341 None Open rpm: add thin-arbiter package 2019-03-13 01:48:57 UTC
Gluster.org Gerrit 22374 None Merged release-notes: add status of gd2 and a highlights section 2019-03-19 14:13:02 UTC
Gluster.org Gerrit 22378 None Open release-notes/6.0: Add ctime feature changes in release notes 2019-03-19 14:13:25 UTC
Gluster.org Gerrit 22379 None Abandoned deprecated xlator upgrade doc 2019-03-26 05:49:01 UTC
Gluster.org Gerrit 22380 None Merged doc: Final version of release-6 release notes 2019-03-19 14:48:44 UTC

Description Shyamsundar 2019-02-06 00:56:04 UTC
Tracker for the release 6.0

Comment 1 Raghavendra G 2019-02-06 03:08:10 UTC
Bug 1664934 - glusterfs-fuse client not benefiting from page cache on read after write

Comment 2 Raghavendra G 2019-02-06 03:09:33 UTC
Bug 1670718 - md-cache should be loaded at a position in graph where it sees stats in write cbk

Comment 3 Worker Ant 2019-02-07 12:26:51 UTC
REVIEW: https://review.gluster.org/22173 (api: Update all future API versions to rel-6) posted (#1) for review on release-6 by Shyamsundar Ranganathan

Comment 4 Worker Ant 2019-02-08 15:48:08 UTC
REVIEW: https://review.gluster.org/22173 (api: Update all future API versions to rel-6) merged (#2) on release-6 by Shyamsundar Ranganathan

Comment 5 Raghavendra G 2019-02-12 03:26:41 UTC
Bug 1676356 - glusterfs FUSE client crashing every few days with 'Failed to dispatch handler'

Comment 6 Worker Ant 2019-02-18 20:04:27 UTC
REVIEW: https://review.gluster.org/22226 (doc: Added initial release notes for release-6) posted (#1) for review on release-6 by Shyamsundar Ranganathan

Comment 7 Worker Ant 2019-02-19 17:10:36 UTC
REVIEW: https://review.gluster.org/22197 (fuse: reflect the actual default for lru-limit option) posted (#2) for review on release-6 by Amar Tumballi

Comment 8 Worker Ant 2019-02-22 04:13:17 UTC
REVIEW: https://review.gluster.org/22226 (doc: Added initial release notes for release-6) merged (#4) on release-6 by Shyamsundar Ranganathan

Comment 9 Worker Ant 2019-02-22 04:57:56 UTC
REVIEW: https://review.gluster.org/22250 (doc: Update release notes for Samba integration) posted (#1) for review on release-6 by Anoop C S

Comment 10 Worker Ant 2019-02-22 13:21:19 UTC
REVISION POSTED: https://review.gluster.org/22197 (fuse: reflect the actual default for lru-limit option) posted (#3) for review on release-6 by Shyamsundar Ranganathan

Comment 11 Worker Ant 2019-02-28 07:08:52 UTC
REVIEW: https://review.gluster.org/22285 (doc: update releasenote) posted (#1) for review on release-6 by Sanju Rakonde

Comment 12 Worker Ant 2019-03-12 11:22:20 UTC
REVIEW: https://review.gluster.org/22341 (rpm: add thin-arbiter package) posted (#1) for review on release-6 by Amar Tumballi

Comment 13 Worker Ant 2019-03-12 20:57:28 UTC
REVIEW: https://review.gluster.org/22250 (doc: Update release notes for Samba integration) merged (#2) on release-6 by Shyamsundar Ranganathan

Comment 14 Worker Ant 2019-03-13 01:48:58 UTC
REVIEW: https://review.gluster.org/22341 (rpm: add thin-arbiter package) merged (#4) on release-6 by Shyamsundar Ranganathan

Comment 15 Worker Ant 2019-03-18 10:30:59 UTC
REVIEW: https://review.gluster.org/22374 (release-notes: add status of gd2 and a highlights section) posted (#1) for review on release-6 by Amar Tumballi

Comment 16 Worker Ant 2019-03-19 07:41:18 UTC
REVIEW: https://review.gluster.org/22378 (release-notes/6.0: Add ctime feature changes in release notes) posted (#2) for review on release-6 by Kotresh HR

Comment 17 Worker Ant 2019-03-19 14:06:36 UTC
REVIEW: https://review.gluster.org/22379 (deprecated xlator upgrade doc) posted (#1) for review on release-6 by Amar Tumballi

Comment 18 Worker Ant 2019-03-19 14:13:03 UTC
REVIEW: https://review.gluster.org/22374 (release-notes: add status of gd2 and a highlights section) merged (#5) on release-6 by Shyamsundar Ranganathan

Comment 19 Worker Ant 2019-03-19 14:13:26 UTC
REVIEW: https://review.gluster.org/22378 (release-notes/6.0: Add ctime feature changes in release notes) merged (#4) on release-6 by Shyamsundar Ranganathan

Comment 20 Worker Ant 2019-03-19 14:19:05 UTC
REVIEW: https://review.gluster.org/22380 (doc: Final version of release-6 release notes) posted (#1) for review on release-6 by Shyamsundar Ranganathan

Comment 21 Worker Ant 2019-03-19 14:48:45 UTC
REVIEW: https://review.gluster.org/22380 (doc: Final version of release-6 release notes) merged (#1) on release-6 by Shyamsundar Ranganathan

Comment 22 Shyamsundar 2019-03-25 16:33:15 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-6.0, please open a new bug report.

glusterfs-6.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-March/000120.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.