Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 167171 - printf mis match
Summary: printf mis match
Keywords:
Status: CLOSED DUPLICATE of bug 158393
Alias: None
Product: Fedora
Classification: Fedora
Component: amanda
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jay Fenlason
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-08-31 10:05 UTC by David Binderman
Modified: 2014-08-31 23:27 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-31 14:38:04 UTC


Attachments (Terms of Use)

Description David Binderman 2005-08-31 10:05:05 UTC
Description of problem:
I just tried to compile package amanda-2.4.5-3 from Redhat
Fedora Core development tree with the Intel C compiler.

The compiler said

sendsize.c(559): warning #267: the format string requires additional arguments

The source code is

           dbprintf(("%s: Can't use CALCSIZE for samba estimate: %s %s\n",
                     est->amname, est->dirname));

Three %s specifiers, two trailing parameters.

Suggest code rework. 

You might consider it prudent to add compiler flag
-Wall to the GNU C compiler command line to prevent this kind of problem
happening again in the future. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jay Fenlason 2005-08-31 14:38:04 UTC
 

*** This bug has been marked as a duplicate of 158393 ***


Note You need to log in before you can comment on or make changes to this bug.