Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 167123 - text console is completely dark after exiting from X
Summary: text console is completely dark after exiting from X
Keywords:
Status: CLOSED DUPLICATE of bug 161242
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-08-30 16:51 UTC by Razvan Sandu
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-30 17:19:42 UTC


Attachments (Terms of Use)

Description Razvan Sandu 2005-08-30 16:51:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
When system exits from X mode after ending a work session (in runlevel 3 - it returns from X mode to text console), screen remains completely dark.

Keyboard works OK, the system is not "hanged" - one can type commands "blindly".


The only solution I've found till now is a complete reboot (press Ctrl-Alt-Del).





Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-37 and all previous versions in FC4

How reproducible:
Sometimes

Steps to Reproduce:
1. Install a fresh FC4 + all updates.
2. Prepare system for booting in runlevel 3 (modify /etc/inittab) and reboot.
3. Start an X session using "startx".
4. Exit for the X session choosing "Desktop" -> "Log out".


Actual Results:  The screen remains dark; text console doesn't show up after the X session.
Keyboard works OK, the system is not "hanged" - one can type commands "blindly".

I must do a complete reboot to regain control (by pressing Ctrl-Alt-Del).

On SOME systems this behaviour dissapeared by itself (probably after some automatic updates made by yum).

Expected Results:  Normal text console should show up (runlevel 3).


Additional info:

I've tested this behaviour on various monitors and video adapters, but I mainly use:

- Asus P4P800-MX mainboards with integrated video adapter (Intel 865);
- no-name CRT monitor PK-772 (made in China), Hsync 30-70 KHz, Vsync 50-150Hz, max resoluton 1280 x 1024; recommended resolution 1024 x 768@85 Hz

Manually adjusting (fine-tuning) xorg.conf seems to be useless.

Comment 1 Mike A. Harris 2005-08-30 17:19:42 UTC

*** This bug has been marked as a duplicate of 161242 ***


Note You need to log in before you can comment on or make changes to this bug.