Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 16684 - rpm dumps core with duplicate remove package request
Summary: rpm dumps core with duplicate remove package request
Keywords:
Status: CLOSED DUPLICATE of bug 7771
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
: 15636 17242 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-21 15:41 UTC by phostetl
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-09-05 14:11:42 UTC


Attachments (Terms of Use)

Description phostetl 2000-08-21 15:41:56 UTC
I inadvertently pasted the same package name in the command twice and rpm
dumped core. 

The text of the error is listed below:

[root@gibson cgi-bin]# rpm -e pilot-link
error: removing these packages would break dependencies:
	pilot-link is needed by kpilot-3.1b9-4
	pilot-link is needed by pilot-link-devel-0.9.3-3
	libpisock.so.3 is needed by kpilot-3.1b9-4
[root@gibson cgi-bin]# rpm -e pilot-link kpilot-3.1b9-4
pilot-link-devel-0.9.3-3 kpilot-3.1b9-4
cannot read packages named kpilot for uninstall
Segmentation fault (core dumped)
[root@gibson cgi-bin]# rpm -e pilot-link kpilot-3.1b9-4
pilot-link-devel-0.9.3-3               
error: package pilot-link is not installed
error: package kpilot-3.1b9-4 is not installed
error: package pilot-link-devel-0.9.3-3 is not installed
[root@gibson cgi-bin]# rpm -q rpm
rpm-3.0.5-9.6x

Comment 1 Jeff Johnson 2000-09-05 14:04:25 UTC
*** Bug 17242 has been marked as a duplicate of this bug. ***

Comment 2 Jeff Johnson 2000-09-05 14:11:41 UTC
*** Bug 15636 has been marked as a duplicate of this bug. ***

Comment 3 Jeff Johnson 2001-01-09 16:08:03 UTC
Collecting duplicates at bugzilla #7771

*** This bug has been marked as a duplicate of 7771 ***


Note You need to log in before you can comment on or make changes to this bug.