Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 166782 - libdb shipped with e-d-s broken which breaks local address book.
Summary: libdb shipped with e-d-s broken which breaks local address book.
Keywords:
Status: CLOSED DUPLICATE of bug 166742
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution-data-server
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-08-25 17:44 UTC by Christian Kellner
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-25 21:15:56 UTC


Attachments (Terms of Use)

Description Christian Kellner 2005-08-25 17:44:46 UTC
Opening local address book failed with 2.3.8. I think it is related to broken libdb:

(evolution-data-server:3059): libebookbackend-WARNING **: db_env_open failed with 22

22 is EINVAL and from db API doc (http://www.sleepycat.com/docs/api_c/frame.html):
<quote>
EINVAL
    If the DB_THREAD flag was specified and fast mutexes are not available for
this architecture; The DB_HOME or TMPDIR environment variables were set, but
empty; An incorrectly formatted NAME VALUE entry or line was found; or if an
invalid flag value or parameter was specified.
</quote>

It (2.3.8) works on ubuntu breezy without any problems.

Comment 1 Dave Malcolm 2005-08-25 21:15:56 UTC

*** This bug has been marked as a duplicate of 166742 ***


Note You need to log in before you can comment on or make changes to this bug.