Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 166703 - error writing partition table during install; device or resource busy
Summary: error writing partition table during install; device or resource busy
Keywords:
Status: CLOSED DUPLICATE of bug 160693
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-08-24 19:29 UTC by Scott D. Anderson
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-25 14:51:08 UTC


Attachments (Terms of Use)

Description Scott D. Anderson 2005-08-24 19:29:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3) Gecko/20040924

Description of problem:
CD installation of FC4.  I get to the point where it's writing the partition table and formatting the partitions, and the installation fails immediately with the following error message.

error: Error: Error informing the kernel about modifications to partition /dev/hda3 - Device or resource busy.  This means Linux won't know about any changes you made to /dev/hda3 until you reboot - so you shouldn't mount it or use it in any way before rebooting.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
This is from a CD install.  I put in the Fedora Core 4 disc #1 and booted. At the  boot prompt, I type "mediacheck," which gets an error, of course. I then type "linux mediacheck" and check the CD, which passes.  I then start the install.  The initial Q&A goes normally:  keyboard, mouse, language, and I choose "workstation install."  Then, I get to partitioning.  This machine is a dual boot machine with a 10 GB WinXP partition, a 100 MB /boot partition, a 10 GB Linux partition (RedHat WS) and a 50 GB VFAT parition.  I choose "remove all Linux partitions" and I choose "automatically partition."  The partitioning scheme it chooses is:

hda1   NTFS  (WinXP)
hda2   /boot  
hda3   LVM PV  (10 GB)
hda4   extended
hda5   VFAT  50 GB
hda6   VFAT  102 MB

There are two logical volumes made from the PV, namely swap (1GB) and / (9GB).  Everything looks fine, though I find hda6 somewhat puzzling.  The 50GB vfat partition is intended to be shared between the two OSes.

We then continue on through setting the bootloader password, confirming DHCP, declining a firewall, setting root password, and selecting packages (I chose the  default).  All of which proceeds normally; I've done this dozens of times.

Next, we get to the climactic point of no return, and I click on "go ahead."  The error then happens *immediately*, and it says:

error: Error: Error informing the kernel about modifications to partition /dev/hda3 - Device or resource busy.  This means Linux won't know about any changes you made to /dev/hda3 until you reboot - so you shouldn't mount it or use it in any way before rebooting.

I get two options:  ignore or cancel. If I choose ignore, the installation fails anyhow.  No changes were made to the partitions, since I'm able to boot into the old system normally.

I set up the partitions by myself once, and got the same error, so it's not the automatic partitioning that fails.  If I recall correctly, if I use a rescue CD, and delete all the linux partitions and then tell it to use the free space, I think that works.  If it's important, I'll try this, but I want to post this bug before too much time passes.

Note that the code is running on a Gateway 4100; I don't know if it's hardware-dependent.


Actual Results:  I get two options:  ignore or cancel. If I choose ignore, the installation fails anyhow.  I get a chance to save the system state to a floppy; I've attached that below.

No changes were made to the partitions, since I'm able to boot into the old system normally.


Expected Results:  It should have said "formatting / " and then started installing packages.


Additional info:

Comment 1 Scott D. Anderson 2005-08-24 19:33:25 UTC
It offered me the option to save the state to a floppy, which I did.  However,
when I try to open (say, with Emacs) or copy the file, I get an I/O error, and I
only get 16384 bytes out of 873158 (if the byte counts can be trusted).  I've
attached that anacdump.txt file.



Comment 2 Jeremy Katz 2005-08-25 14:51:08 UTC

*** This bug has been marked as a duplicate of 160693 ***


Note You need to log in before you can comment on or make changes to this bug.