Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 166479 - camel_exception_get_id (NULL) - assertion failure
Summary: camel_exception_get_id (NULL) - assertion failure
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: rawhide
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC5Target
TreeView+ depends on / blocked
 
Reported: 2005-08-22 10:58 UTC by Ivan Gyurdiev
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-01-31 07:52:54 UTC


Attachments (Terms of Use)

Description Ivan Gyurdiev 2005-08-22 10:58:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050818 Fedora/1.1-0.2.7.deerpark.alpha2.1 Firefox/1.0+

Description of problem:
Crashes on startup. GDB says:
==============================

(evolution:3079): camel-WARNING **: camel_exception_get_id called with NULL parameter.

camel-imap-provider-ERROR **: file camel-imap-command.c: line 180 (imap_command_start): assertion failed: (store->ostream)
aborting...

Program received signal SIGABRT, Aborted.
[Switching to Thread -1303114832 (LWP 3083)]
0x0732f8d5 in raise () from /lib/libc.so.6
(gdb) info stack
#0  0x0732f8d5 in raise () from /lib/libc.so.6
#1  0x07330e0b in abort () from /lib/libc.so.6
#2  0x009b6dc0 in g_logv () from /usr/lib/libglib-2.0.so.0
#3  0x009b6df4 in g_log () from /usr/lib/libglib-2.0.so.0
#4  0x009b6e60 in g_assert_warning () from /usr/lib/libglib-2.0.so.0
#5  0x05498752 in camel_imap_command_continuation () from /usr/lib/evolution-data-server-1.2/camel-providers/libcamelimap.so
#6  0x05498830 in camel_imap_command () from /usr/lib/evolution-data-server-1.2/camel-providers/libcamelimap.so
#7  0x0549ac15 in camel_imap_folder_new () from /usr/lib/evolution-data-server-1.2/camel-providers/libcamelimap.so
#8  0x0549d593 in camel_imap_folder_selected () from /usr/lib/evolution-data-server-1.2/camel-providers/libcamelimap.so
#9  0x07bc1b5f in camel_disco_folder_cache_message () from /usr/lib/libcamel-provider-1.2.so.6
#10 0x07bd02d4 in camel_folder_append_message () from /usr/lib/libcamel-provider-1.2.so.6
#11 0x07bc43cb in camel_filter_driver_remove_rule_by_name () from /usr/lib/libcamel-provider-1.2.so.6
#12 0x00e61988 in e_sexp_term_eval () from /usr/lib/libedataserver-1.2.so.4
#13 0x00e61a7a in e_sexp_term_eval () from /usr/lib/libedataserver-1.2.so.4
#14 0x00e619d9 in e_sexp_term_eval () from /usr/lib/libedataserver-1.2.so.4
#15 0x00e62ec1 in e_sexp_eval () from /usr/lib/libedataserver-1.2.so.4
#16 0x07bc4ef1 in camel_filter_driver_filter_message () from /usr/lib/libcamel-provider-1.2.so.6
#17 0x07bc5156 in camel_filter_driver_filter_folder () from /usr/lib/libcamel-provider-1.2.so.6
#18 0x02296e55 in mail_offline_handler_new () from /usr/lib/evolution/2.4/components/libevolution-mail.so
#19 0x022972cc in mail_filter_junk () from /usr/lib/evolution/2.4/components/libevolution-mail.so
#20 0x022956f9 in mail_enable_stop () from /usr/lib/evolution/2.4/components/libevolution-mail.so
#21 0x00e608c1 in e_thread_busy () from /usr/lib/libedataserver-1.2.so.4
#22 0x00a7394f in start_thread () from /lib/libpthread.so.0
#23 0x073c8a4e in clone () from /lib/libc.so.6
(gdb)


Version-Release number of selected component (if applicable):
evolution-2.3.7-3

How reproducible:
Always

Steps to Reproduce:

  

Additional info:

Comment 1 Dave Malcolm 2005-08-22 16:01:32 UTC
Thanks for this report.

Which version of evolution-data-server do you have installed?  

Please can you install the -debuginfo package for e-d-s and regenerate a
backtrace.  Thanks.

BTW, are you doing anything "interesting" with SELinux, that might have
trigerred this.

Comment 2 Ivan Gyurdiev 2005-08-22 17:18:21 UTC
Selinux is currently off.
===========================

[Thread -1313657936 (LWP 4723) exited]
[New Thread -1313657936 (LWP 4724)]
[New Thread -1324541008 (LWP 4725)]

(evolution:4712): Gdk-CRITICAL **: gdk_gc_set_foreground: assertion `GDK_IS_GC
(gc)' failed
[New Thread -1439954000 (LWP 4726)]

(evolution:4712): camel-WARNING **: camel_exception_get_id called with NULL
parameter.

camel-imap-provider-ERROR **: file camel-imap-command.c: line 180
(imap_command_start): assertion failed: (store->ostream)
aborting...

Program received signal SIGABRT, Aborted.
[Switching to Thread -1303172176 (LWP 4722)]
0x06ceb8d5 in raise () from /lib/libc.so.6
(gdb) bt
#0  0x06ceb8d5 in raise () from /lib/libc.so.6
#1  0x06cece0b in abort () from /lib/libc.so.6
#2  0x00a42dc0 in g_logv () from /usr/lib/libglib-2.0.so.0
#3  0x00a42df4 in g_log () from /usr/lib/libglib-2.0.so.0
#4  0x00a42e60 in g_assert_warning () from /usr/lib/libglib-2.0.so.0
#5  0x06f88752 in imap_command_start (store=0xa9700980, folder=0x0,
cmd=0xa9745b70 "APPEND INBOX.fedora-selinux {5244}",
    ex=0x96d9ad8) at camel-imap-command.c:181
#6  0x06f88830 in camel_imap_command (store=0xa9700980, folder=0x0,
ex=0x96d9ad8, fmt=0x6f9aefb "APPEND %F%s%s {%d}")
    at camel-imap-command.c:110
#7  0x06f8ac15 in do_append (folder=0xa9702260, message=0x9806a38, info=Variable
"info" is not available.
) at camel-imap-folder.c:1225
#8  0x06f8d593 in imap_append_online (folder=0xa9702260, message=0x9806a38,
info=0x9a196c8, appended_uid=0x0, ex=0x96d9ad8)
    at camel-imap-folder.c:1279
#9  0x0461db5f in disco_append_message (folder=0xa9702260, message=0x9806a38,
info=0x9a196c8, appended_uid=0x0,
    ex=0x96d9ad8) at camel-disco-folder.c:369
#10 0x0462c2d4 in camel_folder_append_message (folder=0xa9702260,
message=0x9806a38, info=0x9a196c8, appended_uid=0x0,
    ex=0x96d9ad8) at camel-folder.c:649
#11 0x046203cb in do_move (f=0x96f4f80, argc=1, argv=0xb2532210,
driver=0x9727f90) at camel-filter-driver.c:546
#12 0x00455988 in e_sexp_term_eval (f=0x96f4f80, t=0x9a57bf0) at e-sexp.c:710
#13 0x00455a7a in term_eval_begin (f=0x96f4f80, argc=1, argv=0x9a57288,
data=0x507004) at e-sexp.c:654
#14 0x004559d9 in e_sexp_term_eval (f=0x96f4f80, t=0x9a57b00) at e-sexp.c:700
#15 0x00456ec1 in e_sexp_eval (f=0x96f4f80) at e-sexp.c:1304
#16 0x04620ef1 in camel_filter_driver_filter_message (driver=0x9727f90,
message=0x0, info=0x9a196c8,
    uid=0x98062d0 "1058546013.162293", source=0x9a2ee60, source_url=0x9806fe0
"pop://ivg2@postoffice9.mail.cornell.edu/",
    original_source_url=Variable "original_source_url" is not available.
) at camel-filter-driver.c:1457
#17 0x04621156 in camel_filter_driver_filter_folder (driver=0x9727f90,
folder=0x9a2ee60, cache=0x981b418, uids=0x9a2276c,
    remove=1, ex=0x96d9ad8) at camel-filter-driver.c:1275
#18 0x0149ce55 in mail_offline_handler_new () from
/usr/lib/evolution/2.4/components/libevolution-mail.so
#19 0x0149d2cc in mail_filter_junk () from
/usr/lib/evolution/2.4/components/libevolution-mail.so
#20 0x0149b6f9 in mail_enable_stop () from
/usr/lib/evolution/2.4/components/libevolution-mail.so
#21 0x004548c1 in thread_dispatch (din=0x959c648) at e-msgport.c:826
#22 0x001a094f in start_thread () from /lib/libpthread.so.0
#23 0x06d84a4e in clone () from /lib/libc.so.6


Comment 3 Ivan Gyurdiev 2005-08-22 17:25:32 UTC
e-d-s is version 1.3.7-2.


Comment 4 Ray Strode [halfline] 2006-01-27 20:26:01 UTC
Hi Ivan,

Are you seeing this problem with rawhide?

Comment 5 Ivan Gyurdiev 2006-01-30 18:38:13 UTC
Well, in the 5 months since this bug was filed:

- I switched back to thunderbird, as it now seems the superior mail client
- I reinstalled the OS (twice)
- I switched to x86_64 architecture

So, the environment now is a bit different. Since I don't use evolution on a
regular basis anymore, it will be difficult to reproduce the bug. All I can say
is, it starts up without crashing...


Note You need to log in before you can comment on or make changes to this bug.