Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 166210 - microcode device /dev/cpu/microcode doesn't exist? after upgrade to RHEL4
Summary: microcode device /dev/cpu/microcode doesn't exist? after upgrade to RHEL4
Status: CLOSED DUPLICATE of bug 160833
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel-utils
Version: 4.0
Hardware: i386
OS: Linux
Target Milestone: ---
: ---
Assignee: Dave Jones
QA Contact: Brian Brock
: 173861 (view as bug list)
Depends On:
TreeView+ depends on / blocked
Reported: 2005-08-17 21:04 UTC by Brian McEntire
Modified: 2015-01-04 22:21 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2005-09-14 06:20:54 UTC
Target Upstream Version:

Attachments (Terms of Use)

Description Brian McEntire 2005-08-17 21:04:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Debian/1.7.8-1

Description of problem:
When switching from various run levels (to diagnose a separate problem (XDMCP access) I see these warnings:

/etc/init.d/microcode_ctl: microcode device /dev/cpu/microcode doesn't exist?

Indeed /dev/cpu/microcode does not exist. 

If I 'modprobe microcode'

The directory is created (actually a symlink):
# ls -ld /dev/cpu/microcode
lrwxrwxrwx  1 root root 12 Aug 17 16:58 /dev/cpu/microcode -> ../microcode

Rerunning /etc/sbin/init.d/microcode_ctl (as will happen when switching to a higher run level) now works:
# service microcode_ctl start
Applying Intel Microcode update:                           [  OK  ]

However, if I run it again (or drop run levels and later up the run level) the warning comes back:
# service microcode_ctl start
/etc/init.d/microcode_ctl: microcode device /dev/cpu/microcode doesn't exist?

It appears the cause of this is that the /etc/init.d/microcode boot script does an 'rmmod microcode' at the end of it's start routine.

This seems like a bug, or there should be a way to quiet this warning or prevent microcode_ctl from running each time I switch run levels.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. On a booted system, run 'service microcode_ctl start'


1b. init 3, wait a few seconds, init 5, watch for the error on the console


Actual Results:  /etc/init.d/microcode_ctl: microcode device /dev/cpu/microcode doesn't exist?

Expected Results:  Applying Intel Microcode update:                           [  OK  ]

... or possibly something like:
Microcode update previously applied, skipping              [  OK  ]

Additional info:

Comment 1 Bert DeKnuydt 2005-09-08 13:05:31 UTC
Exactly the same story on FC4 ...

Comment 2 Florin Andrei 2005-09-13 19:58:00 UTC
I was able to fix this issue on FC4 by creating the executable file named
/etc/sysconfig/modules/microcode.modules with the following content:

/sbin/modprobe microcode

After that microcode_ctl works fine when booting up.

Comment 3 Dave Jones 2005-09-14 05:55:46 UTC
There's been an FC4 errata for a while.  1.11-1.21 should have it fixed.
RHEL4 will have it fixed when U2 ships.

Comment 4 Florin Andrei 2005-09-14 05:58:58 UTC
(In reply to comment #3)
> There's been an FC4 errata for a while.  1.11-1.21 should have it fixed.
> RHEL4 will have it fixed when U2 ships.

And yet it's exactly 1.11-1.21 that didn't work after reboot on my FC4 system.
Creating the modules script fixed it.

Comment 5 Dave Jones 2005-09-14 06:15:08 UTC
argh. it's only fixed in rawhide right now. It's fixed in FC4 CVS too, just not
built. I'll build it and push it out right now (along with an update to the

Comment 6 Dave Jones 2005-09-14 06:20:54 UTC

*** This bug has been marked as a duplicate of 160833 ***

Comment 7 oliver b. 2005-11-22 23:54:01 UTC
*** Bug 173861 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.