Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 166113 - setsysfont uses wrong variable name
Summary: setsysfont uses wrong variable name
Keywords:
Status: CLOSED DUPLICATE of bug 159706
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-08-17 00:10 UTC by Ulrich Drepper
Modified: 2014-03-17 02:55 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-19 07:05:39 UTC


Attachments (Terms of Use)

Description Ulrich Drepper 2005-08-17 00:10:55 UTC
Description of problem:
In the setsysfont script there are currently the following lines:

  if [ -n "$SYSFONTACM" ]; then
    if [ ! -f /lib/kbd/consoletrans/$SYSFONTACM_to_uni.trans ]; then

The second line looks suspicious.  There is no variable SYSFONTACM_to_uni. 
Looking at the content of /lib/kbd/consoletrans I suspect this should be

  if [ ! -f /lib/kbd/consoletrans/${SYSFONTACM}_to_uni.trans ]; then


Version-Release number of selected component (if applicable):
initscripts-8.11.1-1

Comment 1 Bill Nottingham 2005-08-19 07:05:39 UTC
Whoops, I need to get that built at some point.

*** This bug has been marked as a duplicate of 159706 ***


Note You need to log in before you can comment on or make changes to this bug.